
<!DOCTYPE html>
<html>
<head>
<script type="text/javascript">
//<![CDATA[
try{if (!window.CloudFlare) {var CloudFlare=[{verbose:0,p:1486145324,byc:0,owlid:"cf",bag2:1,mirage2:0,oracle:0,paths:{cloudflare:"/cdn-cgi/nexp/dok3v=1613a3a185/"},atok:"35a3d3f22ddf7e7f613350ff2e4ce6b0",petok:"02e634e0c5d2f64b721631fae044e2acd637a1c6-1486505740-1800",zone:"popmatters.com",rocket:"0",apps:{"ga_key":{"ua":"UA-286897-1","ga_bs":"2"}}}];!function(a,b){a=document.createElement("script"),b=document.getElementsByTagName("script")[0],a.async=!0,a.src="//ajax.cloudflare.com/cdn-cgi/nexp/dok3v=f2befc48d1/cloudflare.min.js",b.parentNode.insertBefore(a,b)}()}}catch(e){};
//]]>
</script>
<script type="text/javascript" src="//preamp-clients.header.tech/popmattershome.js"></script>
<script>window.mrf={host:"bc.marfeel.com",dt:1},function(e,t,o,i,a,n,r){function d(){x&&(e.cookie="fromt=yes;path=/;expires="+new Date(Date.now()+18e5).toGMTString(),o.reload())}var x=!/marfeelgarda=no|fromt=yes/i.test(n+";"+a);if((/(ipad.*?OS )(?!1_|2_|3_|4_|X)|mozilla.*android (?!(1|2|3)\.)[0-9](?!.*mobile)|\bSilk\b/i.test(i)&&2&r.dt||/(ip(hone|od).*?OS )(?!1_|2_|3_|4_|X)|mozilla.*android (?!(1|2|3)\.)[0-9].*mobile|bb10/i.test(i)&&1&r.dt||/marfeelgarda=off/i.test(n))&&t===t.top){x&&e.write('<plaintext style="display:none">');var l="script",m=setTimeout(d,1e4),c=e.createElement(l),f=e.getElementsByTagName(l)[0];c.src="//bc.marfeel.com/statics/marfeel/gardac.js",c.onerror=d,c.onload=function(){clearTimeout(m)},f.parentNode.insertBefore(c,f)}}(document,window,location,navigator.userAgent,document.cookie,location.search,window.mrf);</script>
<title>Save Ferris: Checkered Past | PopMatters</title>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8"/>
<meta name="viewport" content="width=device-width, initial-scale=1.0"/>
<meta property="og:title" content="Save Ferris: Checkered Past"/>
<meta property="og:type" content="article"/>
<meta property="og:image" content="http://images.popmatters.com/news_art/s/save-ferris-2017-pressphoto-650.jpg"/>
<meta property="og:url" content="http://www.popmatters.com/review/save-ferris-checkered-past/"/>
<meta property="og:site_name" content="PopMatters"/>
<meta property="og:description" content="Save Ferris' first release in 18 years is enjoyable but not exactly a triumphant return for the third wave ska act."/>
<meta property="fb:app_id" content="117106511637048"/>
<meta name="title" content="Save Ferris: Checkered Past">
<meta name="description" content="Save Ferris first release in 18 years is enjoyable but not exactly a triumphant return for the third wave ska act.">
<meta name="keywords" content="Save Ferris, Checkered Past, WITHYN, save ferris, ska, ska punk, Articles, PopMatters"/>
<link rel="canonical" href="http://www.popmatters.com/review/save-ferris-checkered-past/"/>
<link rel="image_src" href="http://images.popmatters.com/news_art/s/save-ferris-2017-pressphoto-650.jpg"/>
<link rel="shortcut icon" href="//cdn.popmatters.com/favicon.ico"/>
<link rel="alternate" type="application/rss+xml" title="PopMatters" href="http://www.popmatters.com/feeds"/>
 
<link rel="stylesheet" href="//cdn.popmatters.com/css/bootstrap.min.css"/>
<link rel="stylesheet" href="//cdn.popmatters.com/css/bootstrap-theme.min.css"/>
<link rel="stylesheet" type="text/css" href="//cdn.popmatters.com/css/site.css?ver=1"/>
<link rel="stylesheet" type="text/css" href="//cdn.popmatters.com/css/img-hover-effect.css"/>
<link rel="stylesheet" type="text/css" href="/assets/html/assets/css/exsite.css"/>
<script src="//cdn.popmatters.com/js/jquery.min.js"></script>
<script src="//cdn.popmatters.com/js/bootstrap.min.js"></script>
<script src="//cdn.popmatters.com/js/jquery.mailme.js"></script>
<script type="text/javascript" src="http://www.google.com/jsapi?key=ABQIAAAAH4JgP4BOUcEZrmym1iRd_RSyn3Ussp_q00hrVkBItQbm3DCt9BTAjhw3rjccpEVEWKatp8OxckzAfg"></script>
<script src="http://platform.twitter.com/widgets.js" type="text/javascript"></script>
 
<script src="http://www.google-analytics.com/urchin.js" type="text/javascript"></script><script type="text/javascript">_uacct = "UA-286897-1"; urchinTracker();</script>
<script type="text/javascript">/* CloudFlare analytics upgrade */
</script>
<script src="http://www.google-analytics.com/urchin.js" type="text/javascript"></script><script type="text/javascript">_uacct = "UA-286897-1"; urchinTracker();</script>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-286897-1', 'auto');
  ga('send', 'pageview');

</script>
 
<script>
  var _comscore = _comscore || [];
  _comscore.push({ c1: "2", c2: "22614133" });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>
<noscript>
<img src="http://b.scorecardresearch.com/p?c1=2&c2=22614133&cv=2.0&cj=1"/>
</noscript>
 
<script id="ourdata-invite-decision" src="https://webapp.ourdata.us/js/complete.js" async></script>
<script type="text/javascript">
/* <![CDATA[ */
var _gaq = _gaq || [];
_gaq.push(['_setAccount', 'UA-286897-1']);
_gaq.push(['_trackPageview']);

(function() {
var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
})();

(function(b){(function(a){"__CF"in b&&"DJS"in b.__CF?b.__CF.DJS.push(a):"addEventListener"in b?b.addEventListener("load",a,!1):b.attachEvent("onload",a)})(function(){"FB"in b&&"Event"in FB&&"subscribe"in FB.Event&&(FB.Event.subscribe("edge.create",function(a){_gaq.push(["_trackSocial","facebook","like",a])}),FB.Event.subscribe("edge.remove",function(a){_gaq.push(["_trackSocial","facebook","unlike",a])}),FB.Event.subscribe("message.send",function(a){_gaq.push(["_trackSocial","facebook","send",a])}));"twttr"in b&&"events"in twttr&&"bind"in twttr.events&&twttr.events.bind("tweet",function(a){if(a){var b;if(a.target&&a.target.nodeName=="IFRAME")a:{if(a=a.target.src){a=a.split("#")[0].match(/[^?=&]+=([^&]*)?/g);b=0;for(var c;c=a[b];++b)if(c.indexOf("url")===0){b=unescape(c.split("=")[1]);break a}}b=void 0}_gaq.push(["_trackSocial","twitter","tweet",b])}})})})(window);
/* ]]> */
</script>
</head>
<body>
 
<div id="OuterWrapper">
<div class="site-left-takeover">
<div class="rightColAdBox"></div>
</div>
<div class="site-right-takeover">
<div class="rightColAdBox"></div>
</div>
<header class="fixedHeader phone-Header">
<div class="news-ticker clearfix"><a href="http://www.popmatters.com/post/124139-popmatters-seeks-essays-1200-to-3000-words-usually-about-any-aspect-/">Call for Essays on Topics in Culture; Present, Past and the Speculative Future</a></div>
<div class="navbar navbar-default" role="navigation">
<div class="container  p-relative">
<div class="navbar-header">
<button type="button" class="navbar-toggle collapsed" data-toggle="collapse" data-target=".navbar-collapse">
<span class="sr-only">Toggle navigation</span>
<span class="icon-bar"></span>
<span class="icon-bar"></span>
<span class="icon-bar"></span>
</button>
<a class="navbar-brand logo" href="/"></a>
</div>
<div class="navbar-collapse collapse">
<div class="navbar-social pull-left hidden-sm hidden-xs">
<a href="http://www.facebook.com/pages/PopMatters/6658573343" title="Follow us on Facebook" target="_blank" class="socialIcon"><i class="fa fa-facebook"></i></a>
<a href="http://twitter.com/popmatters" target="_blank" class="socialIcon"><i class="fa fa-twitter"></i></a>
<a href="https://plus.google.com/u/1/105337662141310391174/about" target="_blank" class="socialIcon"><i class="fa fa-google-plus"></i></a>
<a href="http://www.pinterest.com/popmatters/" target="_blank" class="socialIcon"><i class="fa fa-pinterest"></i></a>
<a href="https://soundcloud.com/popmatters" target="_blank" class="socialIcon"><i class="fa fa-cloud"></i></a>
</div>
<form id="pmSiteSearch" class="navbar-form navbar-right hidden-xs hidden-sm" method="post" action="http://www.popmatters.com/">
<div class='hiddenFields'>
<input type="hidden" name="XID" value="33834f5f8c79666165931585d447c5c0a730985c"/>
<input type="hidden" name="params" value="eyJyZXN1bHRfcGFnZSI6InNlYXJjaFwvcmVzdWx0c19scyJ9"/>
<input type="hidden" name="ACT" value="121"/>
<input type="hidden" name="site_id" value="1"/>
</div>
<span>Search</span>
<div class="form-group">
<input type="text" class="searchInput" name="keywords" id="keywords" autocomplete="off"/>
</div>
</form>
<ul class="nav navbar-nav navbar-right">
<li class="orangeRecent">
<a href="/recent/">Recent</a>
</li>
<li class="menu-search">
<div class="input-group">
<span class="input-group-addon"><i class="fa fa-search"></i></span>
<form id="pmMobSearch" class="navbar-form navbar-right hidden-lg hidden-md" method="post" action="http://www.popmatters.com/">
<div class='hiddenFields'>
<input type="hidden" name="XID" value="a40f006006a1b3aaf61e662e4e52d3970f8beaca"/>
<input type="hidden" name="params" value="eyJyZXN1bHRfcGFnZSI6InNlYXJjaFwvcmVzdWx0c19scyJ9"/>
<input type="hidden" name="ACT" value="121"/>
<input type="hidden" name="site_id" value="1"/>
</div>
<input type="text" class="form-control search-query navbar-search" placeholder="Search" name="keywords" id="keywords">
</form>
</div>
</li>
<li class="dropdown">
<a data-toggle="dropdown" class="dropdown-toggle" href="#">Features <span class="caret"></span></a>
<ul role="menu" class="dropdown-menu">
<li><a href="/features/">Features Home</a></li>
<li><a href="/special/home">Special Sections</a></li>
</ul>
</li>
<li>
<a href="/reviews/">Reviews</a>
</li>
<li>
<a href="/news/">News</a>
</li>
<li>
<a href="/music/">Music</a>
</li>
<li>
<a href="/film/">Film</a>
</li>
<li>
<a href="/books/">Books</a>
</li>
<li>
<a href="/tv/">TV</a>
</li>
<li>
<a href="/comics/">Comics</a>
</li>
<li>
<a href="/games/">Games</a>
</li>
<li>
<a href="/culture/">Culture</a>
</li>
</ul>
</div>
 
</div>
</div>
</header>
 
 
<div class="container">
 
<div class="main-content">
<div align="center"><div id='TopLeaderboard'>
<script type='text/javascript'>
googletag.cmd.push(function() {googletag.display('Topleaderboard');});
</script>
</div></div>
<div class="row content">
<div class="col-md-8 col-xs-12 col-sm-8 left-main-col">
<div class="BreadcrumbsContainer clearfix"><ul><li><span>//</span><a href="/" rel="bookmark">Home</a></li><li><span>//</span><a href="http://www.popmatters.com/pm/music/">Music</a></li><li><span>//</span><a href="/reviews/recent/section/music">Reviews</a></li><li><span>//</span><a href="/artists/save-ferris" rel="bookmark">Save Ferris</a></li></ul></div>
 
<div class="review-banner clearfix">
<div class="pull-left bannerLeft">
<h3>Save Ferris</h3>
<h1> Checkered Past</h1>
</div>
<div class="pull-right bannerRight">
<h4>by <a href="/archive/contributor/299">Chris Conaton</a></h4>
<p class="SourceText">7 February 2017</p>
<div class="social"> <iframe src="http://www.facebook.com/plugins/like.php?href=http://www.popmatters.com/review/save-ferris-checkered-past&layout=button_count&show_faces=false&action=like&width=450&height=20&colorscheme=light" scrolling="no" frameborder="0" allowTransparency="true" style="height: 20px; overflow: hidden; width: 90px;"></iframe>
<a href="https://twitter.com/share" class="twitter-share-button" data-via="PopMatters">Tweet</a> <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script></div>
</div>
<div class="bannerImage"><img src="http://images.popmatters.com/news_art/s/save-ferris-2017-pressphoto-650.jpg" style="vertical-align: top;"/></div>
<div class="bannerText pull-left"><a href="#">Save Ferris' first</a> release in 18 years is enjoyable but not exactly a triumphant return for the third wave ska act.</div>
<div class="author pull-right">&nbsp;</div>
<div class="col-xs-12 hidden-lg hidden-md hidden-sm row"></div>
</div>
 
 
<div class="ShortLine"></div>
 
 
<div class="review-article clearfix">
<span id="aptureStartContent"></span><div class="articleBox" style="float: right;"><img class="sidebarCoverArt" src="http://images.popmatters.com/news_art/s/save_ferris-checkered_past.jpg" alt="cover art"/><h1><a href="http://www.popmatters.com/pm/artists/save-ferris">Save Ferris</a></h1><h2>Checkered Past</h2><h3>(WITHYN)<br/>US: 10 Feb 2017<br/>UK: 10 Feb 2017</h3><div class="BulletListItem BlueDot"><a href="http://www.amazon.com/exec/obidos/redirect?link_code=ur2&tag=popmatters-20&camp=1789&creative=9325&path=external-search%3Fsearch-type=ss%26index=music%26keyword=save+ferris" target="_blank" title="Buy this item from Amazon">Amazon <img src="http://images.popmatters.com/spacer.gif" alt=""/></a><img src="http://www.assoc-amazon.com/e/ir?t=popmatters-20&amp;l=ur2&amp;o=1" width="1" height="1" border="0" alt="" style="border:none !important; margin:0px !important;"/></div><div class="BulletListItem BlueDot"><a href="http://phobos.apple.com/WebObjects/MZSearch.woa/wa/advancedSearchResults?artistTerm=save+ferris" target="_blank" title="Buy this item from iTunes">iTunes <img src="http://images.popmatters.com/spacer.gif" alt=""/></a></div></div> <p>It’s been 18 years since we’ve heard anything from Save Ferris. The band was in the second tier of ska success in the mid-to-late &#8216;90s, putting out an EP and two albums between 1996 and 1999. They never had a big hit on the level of the Mighty Mighty Bosstones’ “The Impression That I Get”, but they had enough momentum to get their cover of “Come on Eileen” on alternative radio. When the ska boom faded away, so did Save Ferris. I remember seeing them live at a one-off gig in the summer of 2001, and during the show singer Monique Powell promised they’d have a new album out by the winter of 2002. That never happened. Instead, guitarist-songwriter Brian Mashburn left the band in 2003 and was soon followed by the rest of the group except for Powell.</p>
<p>Powell revived the Save Ferris name in 2013 with an entirely new lineup, and the new crowdfunded five song EP <i>Checkered Past</i> is this incarnation’s first release. Although litigation involving Powell and the rest of the original lineup ended with Powell receiving some co-writing credits on Save Ferris’ earlier material, Brian Mashburn was always the band’s primary songwriter. Their second album, 1999’s <i>Modified</i>, found them moving away from a pretty strict third-wave ska sound and into a more sustainable ska-punk hybrid with some other successful boundary-pushing songs thrown in. With Powell fully in charge, <i>Checkered Past</i> finds Save Ferris retreating to the ska equivalent of musical comfort food. It sounds much more like the band’s early days.</p>
<p>Opener “Anything” begins with a super fast bassline and is quickly joined by the rest of the band in high-speed skank mode. This only lasts for about 12 seconds before everything calms down to a fast but more conventional ska-punk tempo for the rest of the song. &#8220;Anything&#8221; is the most positive song on the album, with Powell singing about how in love she is and how her significant other is well liked by everyone she knows. Powell is particularly impressed by her line “My cats think that you are the shit”, which, granted, is pretty good, but probably doesn’t need to be sung twice in a row. Despite backing off from its impressive opening high speed, “Anything” is an enjoyable track in the ‘90s ska tradition.</p>
<p>The EP’s other standout track is its fourth, “Do I Even Like You?” This one also moves at a fast clip, but its minor key approach feels appropriate to Powell’s ruminations on how much she likes her current significant other. Her conclusion, “Maybe I like you a little less than I should”, feels more grounded than outright hatred. The song also features some great work from the horn section, particularly the soaring trumpet lick in the chorus. There’s also a great, traditional-sounding trombone solo in the song, which departs from the song’s main style just enough to be distinct.</p>
<p>More problematic is third song “Golden Silence”, which sounds almost exactly the same as “Do I Even Like You?” It’s got the same tempo, same minor key, and a similar groove. Except this song is pure aggression about wanting someone to shut up, which is lyrically less nuanced than the track that follows it. The song does have a solid saxophone solo and organ break going for it, but the two songs feel too similar right next to each other, especially on a five song EP.</p>
<p>Then there’s “New Sound” and “Goodbye Brother”, the record’s two slow songs. Both are competently played and stylistically appropriate. But the former isn’t particularly good, and the latter suffers from some serious ripoff vibes. “New Sound” features toasting from Neville Staple of legendary ska act The Specials. That’s a nice tip of the hat, but the song itself is a bore. </p>
<p><br/></p><center><p><big><big><b>Please don&#8217;t ad block <i>PopMatters</i>.</b><br/>
We are wholly independent, with no corporate backers.<br/>
Simply whitelisting <i>PopMatters</i> is a show of support.<br/>
Thank you.</big></big></p>
</center><p><br/></p>
<p>Despite the toasting and strategically placed crunchy guitar chords, there’s very little energy, and Powell’s half-hearted lyrics about rude girls and rude boys dancing to a new sound are not engaging. “Goodbye Brother” is better lyrically, with Powell singing about the melancholy after a broken relationship. And its mellow, low-key music fits well with the mood of the lyrics. Too bad the vibe and in particular the main horn riff feel stolen from The Specials’ biggest hit, “A Message to You, Rudy.” It’s not an exact match, but as a ska fan, I found the resemblance to be unmistakable and uncomfortably close.</p>
<p><i>Checkered Past</i> is a quick, enjoyable listen but it isn’t exactly a triumphant return for Save Ferris. Powell’s singing voice and sassy attitude are fully intact after the 18-year hiatus. But as a songwriter, Powell is clearly not on her former bandmate Mashburn’s level. Mashburn himself was not the world’s most accomplished writer, but each of Save Ferris’ ‘90s releases had a handful of songs that were true standouts and still hold up in 2017. This EP doesn’t have anything that memorable, but at least these tracks will fit in comfortably with the songs from the band’s heyday on their upcoming comeback tour.</p></p><span id="aptureEndContent"></span>
 
<div class="ShortLine"></div>
 
 
<div class="rating clearfix">
<h3 class="inline">Checkered Past </h3>
<p><span class="TextTitle">Rating: </span><i class="fa fa-star"></i><i class="fa fa-star"></i><i class="fa fa-star"></i><i class="fa fa-star"></i><i class="fa fa-star"></i><i class="fa fa-star grayIcon"></i><i class="fa fa-star grayIcon"></i><i class="fa fa-star grayIcon"></i><i class="fa fa-star grayIcon"></i><i class="fa fa-star grayIcon"></i></div>
 
<div class="social-share clearfix"> Share<span> via</span> <span class="pull-right"> <a onclick="window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=400,width=600,top=100');return false;" href="http://www.facebook.com/sharer.php?u=http://www.popmatters.com/review/save-ferris-checkered-past" class="socialIcon"><i class="fa fa-facebook"></i></a> <a onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=400,width=600,top=100');return false;" href="http://twitter.com/share?text=Save Ferris: Checkered Past&amp;url=http://www.popmatters.com/review/save-ferris-checkered-past&amp;via=PopMatters" class="socialIcon"><i class="fa fa-twitter"></i></a> <a href="/pm/tools/email/209819" class="socialIcon"><i class="fa fa-envelope"></i></a> </span> </div>
</div>
 
 
 
<div class="clearfix">
<div class="TagsBox">Topics: <a href="/pm/archive/tag/save+ferris/">save ferris</a> | <a href="/pm/archive/tag/ska/">ska</a> | <a href="/pm/archive/tag/ska+punk/">ska punk</a></div>
<div class="ClearingDiv"></div>
</div>
 
 
<div style="text-align: center;"><center><div class="lineDiv">&nbsp;</div><form action="https://www.paypal.com/cgi-bin/webscr" method="post" target="_top">
<input type="hidden" name="cmd" value="_s-xclick">
<input type="hidden" name="hosted_button_id" value="FUJB8DHRKDTZE">
<input type="image" src="https://www.paypalobjects.com/en_US/i/btn/btn_donateCC_LG.gif" border="0" name="submit" alt="PayPal - The safer, easier way to pay online!">
<img alt="" border="0" src="https://www.paypalobjects.com/en_US/i/scr/pixel.gif" width="1" height="1">
</form>
<p><b>We all know how critical it is to keep independent voices alive and strong online. Please consider a donation to support our work as an independent publisher devoted to the arts and humanities. Your donation will help <i>PopMatters</i> stay viable through these changing and challenging times where advertising no longer covers our costs. We need your help to keep PopMatters publishing. Thank you.</b></center><div class="lineDiv">&nbsp;</div></div>
 
 
 
<div class="media-section"> <a href="#" class="boxHeading"> <span>//</span>Media </a><iframe width="650" height="385" src="https://www.youtube.com/embed/xr-jpVaO37A" frameborder="0" allowfullscreen></iframe> </div>
 
 
 
<div class="adSpace box hidden-xs">
<div style="text-align: center;"> <br/>
 
<div class="jumbotron hidden-xs hidden-sm">
<div align="center"><div id='BottomLeaderboard'>
<script type='text/javascript'>
googletag.cmd.push(function() {googletag.display('BottomLeaderboard');});
</script>
</div></div>
<script src="http://www.google-analytics.com/urchin.js" type="text/javascript"></script><script type="text/javascript">_uacct = "UA-286897-1"; urchinTracker();</script>
<script type="text/javascript">
var _sf_async_config=
{uid:21097,domain:"popmatters.com"}
;
(function()
{
  function loadChartbeat() 
{
    window._sf_endpt=(new Date()).getTime();
    var e = document.createElement('script');
    e.setAttribute('language', 'javascript');
    e.setAttribute('type', 'text/javascript');
    e.setAttribute('src',
       (("https:" == document.location.protocol) ? "https://a248.e.akamai.net/chartbeat.download.akamai.com/102508/" : "http://static.chartbeat.com/") +
       "js/chartbeat.js");
    document.body.appendChild(e);
  }
  var oldonload = window.onload;
  window.onload = (typeof window.onload != 'function') ?
     loadChartbeat : function() 
{ 
oldonload(); loadChartbeat(); 
};
}
)();
</script>
</div>
</div>
</div>
 
 
<div id="vaInPageRecs"></div>
 
<div class="comments clearfix"> <a href="#" class="boxHeading"> <span>//</span>comments </a>
<div class="SectionBodyContainer Width650_Style1">
<div class="CommentsContainer" id="comments">
<div class="DisqusComments">
<div id="disqus_thread"></div>
<script type="text/javascript">
					var disqus_shortname = 'popmatters';
					var disqus_identifier = '209819';
					var disqus_url = 'http://www.popmatters.com/review/save-ferris-checkered-past/';
					var disqus_title = 'Save Ferris: Checkered Past';

					(function() {
						var dsq = document.createElement('script'); dsq.type = 'text/javascript'; dsq.async = true;
						dsq.src = 'http://' + disqus_shortname + '.disqus.com/embed.js';
						(document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(dsq);
					})();
				</script>
<noscript>Please enable JavaScript to view the <a href="http://disqus.com/?ref_noscript">comments powered by Disqus.</a></noscript>
</div> 
</div>
</div>
<div class="SectionFooterContainer Width650_Style1"></div>
</div>
 
 
 
<div class="adSpace box hidden-md  hidden-sm hidden-lg">
<div style="text-align: center;"> <div id='MobileMPU2'>
<script type='text/javascript'>
googletag.cmd.push(function() {googletag.display('MobileMPU2');});
</script>
</div>
<script src="http://www.google-analytics.com/urchin.js" type="text/javascript"></script><script type="text/javascript">_uacct = "UA-286897-1"; urchinTracker();</script>
<script type="text/javascript">
var _sf_async_config=
{uid:21097,domain:"popmatters.com"}
;
(function()
{
  function loadChartbeat() 
{
    window._sf_endpt=(new Date()).getTime();
    var e = document.createElement('script');
    e.setAttribute('language', 'javascript');
    e.setAttribute('type', 'text/javascript');
    e.setAttribute('src',
       (("https:" == document.location.protocol) ? "https://a248.e.akamai.net/chartbeat.download.akamai.com/102508/" : "http://static.chartbeat.com/") +
       "js/chartbeat.js");
    document.body.appendChild(e);
  }
  var oldonload = window.onload;
  window.onload = (typeof window.onload != 'function') ?
     loadChartbeat : function() 
{ 
oldonload(); loadChartbeat(); 
};
}
)();
</script>
 
<script type="text/javascript">
    document.write(unescape("%3Cscript src='" + (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js'%3E%3C/script%3E"));
</script>
<script type="text/javascript">
    COMSCORE.beacon(
{
        c1:2,
        c2:"6035055",
        c3:"",
        c4:location.href,
        c5:"",
        c6:"",
        c15:""
    }
);
</script>
<noscript>
<img src="http://b.scorecardresearch.com/p?c1=2&c2=6035055&c3=&c4=&c5=&c6=&c15=&cj=1"/>
</noscript>
 </div>
</div>
 
 
</div>
 
  <div class="col-md-4 col-sm-4 col-xs-12 right-main-col">
<div class="adSpace box hidden-xs">
<div style="text-align: center;"> <div id='MPU1'>
<script type='text/javascript'>
googletag.cmd.push(function() {googletag.display('MPU1');});
</script>
</div></div>
</div>
 
<div class="sidebar-review clearfix"> <a href="/reviews/" class="boxHeading"> <span>//</span>Reviews </a><div class="review-img clearfix"><a href="http://www.popmatters.com/review/syd-fin/"><div class="col-md-12 col-sm-12 col-xs-12 noleft noright ReBlackBox"><div class="col-md-6 col-sm-6 col-xs-6 noleft noright ReviewTextBox"><div class="revTxtBlock"><span>Syd</span> Fin</div></div><div class="col-md-6 col-sm-6 col-xs-6 noleft noright"><img src="http://images.popmatters.com/news_art/s/syd-fin-350x350.jpg" class="grayscale"/></div></div></a><a href="http://www.popmatters.com/review/save-ferris-checkered-past/"><div class="col-md-12 col-sm-12 col-xs-12 noleft noright ReGrayBox"><div class="col-md-6 col-sm-6 col-xs-6 noleft noright"><img src="http://images.popmatters.com/news_art/s/save_ferris-checkered_past.jpg" class="grayscale"/></div><div class="col-md-6 col-sm-6 col-xs-6 noleft noright ReviewTextBox"><div class="revTxtBlock"><span>Save Ferris</span> Checkered Past</div></div></div></a><a href="http://www.popmatters.com/review/communions-blue/"><div class="col-md-12 col-sm-12 col-xs-12 noleft noright ReBlackBox"><div class="col-md-6 col-sm-6 col-xs-6 noleft noright ReviewTextBox"><div class="revTxtBlock"><span>Communions</span> Blue</div></div><div class="col-md-6 col-sm-6 col-xs-6 noleft noright"><img src="http://images.popmatters.com/news_art/c/communions-blue.jpg" class="grayscale"/></div></div></a></div><div><div class="ShowHideLinkMore pm-display-toggle" style="display:block;">
<div class="filter"><a href="#" title="more">explore <span>REVIEWS</span> <i class="fa fa-plus"></i></a></div>
</div>
<div class="ShowHideContainer content" style="display:none;">
<h3><a href="http://www.popmatters.com/review/ab-soul-do-what-thou-wilt/">Ab-Soul: Do What Thou Wilt</a> </h3>
<p>Top Dawg's Ab-Soul approaches a lot of interesting thoughts with his newest release, but doesn't exp...</p><h3><a href="http://www.popmatters.com/review/migos-c-u-l-t-u-r-e/">Migos: C U L T U R E</a> </h3>
<p>By being made into a meme, Migos have ensured their lasting presence; even without it, however, C U ...</p><h3><a href="http://www.popmatters.com/review/fufanu-sports/">Fufanu: Sports</a> </h3>
<p>The foreground of Fufanu's Sports lingers like a bad feeling, one that could have been more frighten...</p><h3><a href="http://www.popmatters.com/review/lee-hazlewood-13/">Lee Hazlewood: 13</a> </h3>
<p>Lee Hazlewood's 13 is an excellent -- if uncanny -- addition to his eclectic body of work, a fascina...</p><h3><a href="http://www.popmatters.com/review/black-anvil-as-was/">Black Anvil: As Was</a> </h3>
<p>American black metal outfit returns with a smart, snappy collection that will give air guitarists ca...</p><h3><a href="http://www.popmatters.com/review/ex-cult-negative-growth/">Ex-Cult: Negative Growth</a> </h3>
<p>Negative Growth is the crown jewel of Ex-Cult's trifecta of LPs on In the Red Records....</p><h3><a href="http://www.popmatters.com/review/the-mavericks-all-night-long-vol.-1/">The Mavericks: All Night Live, Vol. 1</a> </h3>
<p>All Night Live, Vol. 1 offers a wildly eclectic, highly enjoyable set of songs performed by the lege...</p></div>
<div class="ShowHideLinkLess pm-display-toggle" style="display:none;">
<div class="filter"><a href="#" title="more">Collapse <span>REVIEWS</span> <i class="fa fa-minus"></i></a></div>
</div>
</div></div>
 
<div class="adSpace box hidden-xs">
<div style="text-align: center;"> <div align="center"><div id='MPU2'>
<script type='text/javascript'>
googletag.cmd.push(function() {googletag.display('MPU2');});
</script>
</div></div></div>
</div>
 
 
 
<div class="mixedMediaBox clearfix">
<a href="/blogs/media-center/" class="boxHeading">
<span>//</span>Mixed media
</a>
<div class="box rightSidebar">
<div class="video" id="mixedvideo"><a href="http://www.popmatters.com/post/austra-i-love-you-more-than-you-love-yourself-singles-going-steady/"><img src="http://images.popmatters.com/news_art/a/austra-2017-pressphoto-credit_renata_raksha-650.jpg"/></a></div>
<div class="clearfix">
<i class="fa fa-circle pull-left rolloverCircle"></i>
<h3 class="blackHeading" data-image="http://images.popmatters.com/news_art/a/austra-2017-pressphoto-credit_renata_raksha-650.jpg" data-href="http://www.popmatters.com/post/austra-i-love-you-more-than-you-love-yourself-singles-going-steady"><a href="http://www.popmatters.com/post/austra-i-love-you-more-than-you-love-yourself-singles-going-steady/" class="mixTitle">Austra </a> <span> "I Love You More Than You Love Yourself" (Singles Going Steady) //</span>
<a href="/music/">Music</a>
</h3>
</div>
<div class="clearfix">
<i class="fa fa-circle pull-left rolloverCircle"></i>
<h3 class="blackHeading" data-image="http://images.popmatters.com/news_art/s/steve-poltz-pressphoto-cr-david-harris-650.jpg" data-href="http://www.popmatters.com/post/steve-poltz-ill-trade-you-donald-trump-for-leonard-cohen-premiere"><a href="http://www.popmatters.com/post/steve-poltz-ill-trade-you-donald-trump-for-leonard-cohen-premiere/" class="mixTitle">Steve Poltz </a> <span> "I'll Trade You Donald Trump for Leonard Cohen" (premiere) //</span>
<a href="/music/">Music</a>
</h3>
</div>
<div class="clearfix">
<i class="fa fa-circle pull-left rolloverCircle"></i>
<h3 class="blackHeading" data-image="http://images.popmatters.com/news_art/r/replacire-2017-pressphoto-tom_couture-650.jpg" data-href="http://www.popmatters.com/post/replacire-horsestance-audio-premiere"><a href="http://www.popmatters.com/post/replacire-horsestance-audio-premiere/" class="mixTitle">Replacire </a> <span> "Horsestance" (audio) (premiere) //</span>
<a href="/music/">Music</a>
</h3>
</div>
<div class="clearfix">
<i class="fa fa-circle pull-left rolloverCircle"></i>
<h3 class="blackHeading" data-image="http://images.popmatters.com/news_art/t/thundercat-2017-drunkalbum-650.jpg" data-href="http://www.popmatters.com/post/thundercat-show-you-the-way-feat.-michael-mcdonald-kenny-loggins"><a href="http://www.popmatters.com/post/thundercat-show-you-the-way-feat.-michael-mcdonald-kenny-loggins/" class="mixTitle">Thundercat </a> <span> "Show You The Way" (feat. Michael McDonald & Kenny Loggins) //</span>
<a href="/music/">Music</a>
</h3>
</div>
<div class="clearfix">
<i class="fa fa-circle pull-left rolloverCircle"></i>
<h3 class="blackHeading" data-image="http://images.popmatters.com/blog_art/g/goldfrapp-2017-pressphoto-650.jpg" data-href="http://www.popmatters.com/post/goldfrapp-anymore-singles-going-steady"><a href="http://www.popmatters.com/post/goldfrapp-anymore-singles-going-steady/" class="mixTitle">Goldfrapp </a> <span> "Anymore" (Singles Going Steady) //</span>
<a href="/music/">Music</a>
</h3>
</div>
<div class="ShowHideLinkMore pm-display-toggle" style="display:block;">
<div class="filter"><a href="#" title="more">Expand <span>MIXED MEDIA</span> <i class="fa fa-plus"></i></a></div>
</div>
<div class="ShowHideContainer" style="display:none;">
<div class="clearfix">
<i class="fa fa-circle pull-left rolloverCircle"></i>
<h3 class="blackHeading" data-image="http://images.popmatters.com/news_art/o/opethera.jpg" data-href="http://www.popmatters.com/post/opeth-era-singles-going-steady"><a href="http://www.popmatters.com/post/opeth-era-singles-going-steady/" class="mixTitle">Opeth </a> <span> "Era" (Singles Going Steady) //</span>
<a href="/music/">Music</a>
</h3>
</div>
<div class="clearfix">
<i class="fa fa-circle pull-left rolloverCircle"></i>
<h3 class="blackHeading" data-image="http://images.popmatters.com/misc_art/p/peck-i-am-not-your-negro-s650.jpg" data-href="http://www.popmatters.com/post/i-am-not-your-negro-endlessly-relevant-particularly-urgent"><a href="http://www.popmatters.com/post/i-am-not-your-negro-endlessly-relevant-particularly-urgent/" class="mixTitle">'I Am Not Your Negro', in Wide Release Today, Is Endlessly Relevant and Particularly Urgent</a> <span> //</span>
<a href="/film/">Film</a>
</h3>
</div>
<div class="clearfix">
<i class="fa fa-circle pull-left rolloverCircle"></i>
<h3 class="blackHeading" data-image="http://images.popmatters.com/news_art/a/ayla_rose-2017-pressphoto-650.jpg" data-href="http://www.popmatters.com/post/ayla-rose-give-me-one-reason-single-premiere"><a href="http://www.popmatters.com/post/ayla-rose-give-me-one-reason-single-premiere/" class="mixTitle">Ayla Rose </a> <span> "Give Me One Reason" (audio) (premiere) //</span>
<a href="/music/">Music</a>
</h3>
</div>
<div class="clearfix">
<i class="fa fa-circle pull-left rolloverCircle"></i>
<h3 class="blackHeading" data-image="http://images.popmatters.com/blog_art/p/pin-carpenter-2017-pressphoto-aaron_farrington-650.jpg" data-href="http://www.popmatters.com/post/mary-chapin-carpenter-peter-wolf-cry-one-more-time-audio-premiere"><a href="http://www.popmatters.com/post/mary-chapin-carpenter-peter-wolf-cry-one-more-time-audio-premiere/" class="mixTitle">Mary Chapin Carpenter & Peter Wolf </a> <span> "Cry One More Time" (audio) (premiere) //</span>
<a href="/music/">Music</a>
</h3>
</div>
<div class="clearfix">
<i class="fa fa-circle pull-left rolloverCircle"></i>
<h3 class="blackHeading" data-image="http://images.popmatters.com/news_art/a/angel_olsen-2016-pressphoto-650.jpg" data-href="http://www.popmatters.com/post/angel-olsen-pops-singles-going-steady"><a href="http://www.popmatters.com/post/angel-olsen-pops-singles-going-steady/" class="mixTitle">Angel Olsen </a> <span> "Pops" (Singles Going Steady) //</span>
<a href="/music/">Music</a>
</h3>
</div>
</div>
<div class="ShowHideLinkLess pm-display-toggle" style="display:none;">
<div class="filter"><a href="#" title="more">Collapse <span>MIXED MEDIA</span> <i class="fa fa-minus"></i></a></div>
</div>
</div>
</div>
<div class="adSpace box hidden-xs">
<div style="text-align: center;"> <div class="rightColAdBox"><div id='MPU3'>
<script type='text/javascript'>
googletag.cmd.push(function() {googletag.display('MPU3');});
</script>
</div></div>
</div>
</div>
 
<div class="blog"> <a href="/blogs/home/" class="boxHeading"> <span>//</span>Blogs </a>
<h2><a href="http://www.popmatters.com/post/the-accidentals-20-questions-part-of-the-movement/">20 Questions: The Accidentals</a></h2>
<h3>// Sound Affects </h3>
<div class="blog-img"> <a href="http://www.popmatters.com/post/the-accidentals-20-questions-part-of-the-movement/"><img alt="" src="http://images.popmatters.com/misc_art/a/accidentals-parking-lot-c3501.jpg" class="imgOverlay"></a> </div>
<div class="row">
<div class="col-md-12">
<p><span class="firstcharacter">"The</span> 20-something renegades may be gearing up for a major label debut in 2017, but at the end of the day, they'll be good with some grilled goat cheese sandwiches.</p>
<a href="http://www.popmatters.com/post/the-accidentals-20-questions-part-of-the-movement/" class="readMore">READ the article</a> </div>
</div>
<div class="row">
<div class="col-md-12">
<ul class="sidebloglist">
<div class="ShowHideLinkMore pm-display-toggle" style="display:block;">
<div class="filter"><a href="#" title="more">explore <span>BLOGS</span> <i class="fa fa-plus"></i></a></div>
</div>
<div class="ShowHideContainer content" style="display:none;">
<li><a href="http://www.popmatters.com/post/that-ribbon-of-highway-sharon-jones-re-shapes-woody-guthries-song/">That Ribbon of Highway: Sharon Jones Re-shapes Woody Guthrie's Song</a><br/><span> by SysAdmin</span> <span class="dateStamp">20 Jan 2017 // 10:19 AM</span></li>
<li><a href="http://www.popmatters.com/post/electric-sixs-dick-valentine-invites-you-to-dance-the-night-away/">Electric Six's Dick Valentine Invites You to Dance the Night Away</a><br/><span> by Jose Solis</span> <span class="dateStamp">12 Jan 2017 // 10:30 AM</span></li>
<li><a href="http://www.popmatters.com/post/sadler-vaden-became-their-muse-podcast/">Sadler Vaden Became Their Muse (Podcast)</a><br/><span> by Sloane Spencer</span> <span class="dateStamp">3 Jan 2017 // 8:30 AM</span></li>
<li><a href="http://www.popmatters.com/post/johnnyswim-takes-atlanta/">Johnnyswim Takes Atlanta</a><br/><span> by Steve Horowitz</span> <span class="dateStamp">29 Dec 2016 // 8:00 AM</span></li>
<li><a href="http://www.popmatters.com/post/brace-yourself-interview-with-allen-thompson/">Brace Yourself: An Interview With Allen Thompson</a><br/><span> by Sloane Spencer</span> <span class="dateStamp">28 Dec 2016 // 7:30 AM</span></li>
<li><a href="http://www.popmatters.com/post/rez-abbasis-invocation-asia-society/">Rez Abbasi's Invocation Premieres 'Unfiltered Universe' Tracks (Photos & Video)</a><br/><span> by Sachyn Mital</span> <span class="dateStamp">23 Dec 2016 // 8:00 AM</span></li>
<li><a href="http://www.popmatters.com/post/2016-the-final-year-of-the-surprise-album-hopefully/">2016: The Final Year of the Surprise Album (Hopefully)</a><br/><span> by SysAdmin</span> <span class="dateStamp">22 Dec 2016 // 11:48 AM</span></li>
<li><a href="http://www.popmatters.com/post/back-and-badder-than-before-an-interview-with-aesop-rock/">Back and Badder Than Before: An Interview With Aesop Rock</a><br/><span> by Danilo Castro</span> <span class="dateStamp">19 Dec 2016 // 8:20 AM</span></li>
<li><a href="http://www.popmatters.com/post/the-1975-bastille-celebrate-the-holidays/">The 1975 + Bastille Celebrate the Holidays with Pandora</a><br/><span> by Sachyn Mital</span> <span class="dateStamp">13 Dec 2016 // 1:15 PM</span></li>
</div>
<div class="ShowHideLinkLess pm-display-toggle" style="display:none;">
<div class="filter"><a href="#" title="more">Collapse <span>BLOGS</span> <i class="fa fa-minus"></i></a></div>
</div>
</ul></div></div>
</div>
 
<div class="adSpace box hidden-xs">
<div style="text-align: center;"> <div align="center"><div id='MPU4'>
<script type='text/javascript'>
googletag.cmd.push(function() {googletag.display('MPU4');});
</script>
</div></div></div>
</div>
</div>
 
</div>
</div>
</div>
</div>
 
<footer>
<div class="footer">
<div class="container">
<div class="row">
<div class="col-md-2 col-sm-3 col-xs-12">
<h4>ABOUT</h4>
<ul class="footerLink">
<li><a href="http://www.popmatters.com/about" title="About">Mission</a>
</li>
<li><a href="http://www.popmatters.com/contributors" title="Staff">Staff</a>
</li>
<li><a href="http://www.popmatters.com/about">Contact</a>
</li>
</ul>
</div>
<div class="col-md-2 col-sm-3 col-xs-12">
<h4>JOIN</h4>
<ul class="footerLink">
<li><a href="http://www.popmatters.com/submissions" title="Submissions">Submissions</a>
</li>
<li><a href="http://www.popmatters.com/book-imprint" title="Book Imprint">Book Series</a>
</li>
</ul>
</div>
<div class="col-md-2 col-sm-3 col-xs-12">
<h4>biz</h4>
<ul class="footerLink">
<li><a href="http://www.popmatters.com/advertising" title="Advertising">Advertising</a>
</li>
<li><a href="http://www.popmatters.com/privacy-policy" title="Privacy Policy">Privacy Policy</a>
</li>
</ul>
</div>
<div class="col-md-2 col-sm-3 col-xs-12">
<h4>FOLLOW us</h4>
<ul class="footerLink">
<li><a href="http://www.popmatters.com/feeds/list" title="RSS">rss</a>
</li>
<li><a target="_blank" href="http://www.facebook.com/pages/PopMatters/6658573343">Facebook</a>
</li>
<li><a target="_blank" href="http://twitter.com/popmatters">Twitter</a>
</li>
<li><a target="_blank" href="https://soundcloud.com/popmatters">Soundcloud</a>
</li>
<li><a target="_blank" href="https://www.pinterest.com/popmatters/">Pinterest</a>
</li>
</ul>
</div>
</div>
</div>
</div>
<div class="copyright"><div class="container">
&copy; 1999-2017 PopMatters.com. All rights reserved. PopMatters.com&trade; and PopMatters&trade; are trademarks of PopMatters Media, Inc.
<span>PopMatters is wholly independently owned and operated.</span>
</div>
</div>
</footer>
 
 
 
<div id='div-gpt-ad-1474999059755-0' style='height:1px; width:1px;'>
<script>
googletag.cmd.push(function() {googletag.display('div-gpt-ad-1474999059755-0');});
</script>
</div>
<script src="http://www.google-analytics.com/urchin.js" type="text/javascript"></script><script type="text/javascript">_uacct = "UA-286897-1"; urchinTracker();</script>
<script type="text/javascript">
var _sf_async_config=
{uid:21097,domain:"popmatters.com"}
;
(function()
{
  function loadChartbeat() 
{
    window._sf_endpt=(new Date()).getTime();
    var e = document.createElement('script');
    e.setAttribute('language', 'javascript');
    e.setAttribute('type', 'text/javascript');
    e.setAttribute('src',
       (("https:" == document.location.protocol) ? "https://a248.e.akamai.net/chartbeat.download.akamai.com/102508/" : "http://static.chartbeat.com/") +
       "js/chartbeat.js");
    document.body.appendChild(e);
  }
  var oldonload = window.onload;
  window.onload = (typeof window.onload != 'function') ?
     loadChartbeat : function() 
{ 
oldonload(); loadChartbeat(); 
};
}
)();
</script>
 
<script src="//cdn.popmatters.com/js/site.js?v=2"></script>
</body>
</html>
