
<!DOCTYPE html>
<html>
<head>
<script type="text/javascript">
//<![CDATA[
var _gaq = _gaq || [];_gaq.push(['_setAccount', 'UA-286897-1']);_gaq.push(['_trackPageview']);(function() {var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);})();(function(b){(function(a){"__CF"in b&&"DJS"in b.__CF?b.__CF.DJS.push(a):"addEventListener"in b?b.addEventListener("load",a,!1):b.attachEvent("onload",a)})(function(){"FB"in b&&"Event"in FB&&"subscribe"in FB.Event&&(FB.Event.subscribe("edge.create",function(a){_gaq.push(["_trackSocial","facebook","like",a])}),FB.Event.subscribe("edge.remove",function(a){_gaq.push(["_trackSocial","facebook","unlike",a])}),FB.Event.subscribe("message.send",function(a){_gaq.push(["_trackSocial","facebook","send",a])}));"twttr"in b&&"events"in twttr&&"bind"in twttr.events&&twttr.events.bind("tweet",function(a){if(a){var b;if(a.target&&a.target.nodeName=="IFRAME")a:{if(a=a.target.src){a=a.split("#")[0].match(/[^?=&]+=([^&]*)?/g);b=0;for(var c;c=a[b];++b)if(c.indexOf("url")===0){b=unescape(c.split("=")[1]);break a}}b=void 0}_gaq.push(["_trackSocial","twitter","tweet",b])}})})})(window);//]]>
</script><script type="text/javascript">
//<![CDATA[
try{if (!window.CloudFlare) {var CloudFlare=[{verbose:0,p:1499703284,byc:0,owlid:"cf",bag2:1,mirage2:0,oracle:0,paths:{cloudflare:"/cdn-cgi/nexp/dok3v=1613a3a185/"},atok:"35a3d3f22ddf7e7f613350ff2e4ce6b0",petok:"f293fe66469d4d52d461d13c66a95dd53b38bb1d-1499832621-1800",zone:"popmatters.com",rocket:"0",apps:{"ga_key":{"ua":"UA-286897-1","ga_bs":"2"}}}];!function(a,b){a=document.createElement("script"),b=document.getElementsByTagName("script")[0],a.async=!0,a.src="//ajax.cloudflare.com/cdn-cgi/nexp/dok3v=85b614c0f6/cloudflare.min.js",b.parentNode.insertBefore(a,b)}()}}catch(e){};
//]]>
</script>
<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>
<script>
  googletag.cmd.push(function() {
  
    var topLeaderboardMapping = googletag.sizeMapping()
    .addSize([0, 0], [])
    .addSize([500, 0], [[468, 60]])
    .addSize([768, 0], [[728, 90]])
    .addSize([965, 0], [[728, 90]])
    .addSize([1010, 0], [[970, 250],[970, 90],[728, 90]]).build();
    
    var MPU1Mapping = googletag.sizeMapping()
    .addSize([0, 0], [])
    .addSize([500, 0], [[300, 250]])
    .addSize([768, 0], [])
    .addSize([965, 0], [[300, 250]])
    .addSize([1010, 0], [[300, 250]]).build();
    
    var MPU2Mapping = googletag.sizeMapping()
    .addSize([0, 0], [])
    .addSize([500, 0], [[300, 250],[300, 600],[160, 600]])
    .addSize([768, 0], [])
    .addSize([965, 0], [[300, 250],[300, 600],[160, 600]])
    .addSize([1010, 0], [[300, 250],[300, 600],[160, 600]]).build();
    
    var MPU3Mapping = googletag.sizeMapping()
    .addSize([0, 0], [])
    .addSize([500, 0], [[300, 250],[300, 600],[160, 600]])
    .addSize([768, 0], [])
    .addSize([965, 0], [[300, 250],[300, 600],[160, 600]])
    .addSize([1010, 0], [[300, 250],[300, 600],[160, 600]]).build();
    
    var bottomLeaderboardMapping = googletag.sizeMapping()
    .addSize([0, 0], [])
    .addSize([500, 0], [[468, 60]])
    .addSize([768, 0], [[728, 90]])
    .addSize([965, 0], [[728, 90]])
    .addSize([1010, 0], [[970, 250],[970, 90],[728, 90]]).build();
    
    var MPU4Mapping = googletag.sizeMapping()
    .addSize([0, 0], [])
    .addSize([500, 0], [[300, 250],[300, 600],[160, 600]])
    .addSize([768, 0], [])
    .addSize([965, 0], [[300, 250],[300, 600],[160, 600]])
    .addSize([1010, 0], [[300, 250],[300, 600],[160, 600]]).build();
    
    function getUrlParameter(name) {
    name = name.replace(/[\[]/, '\\[').replace(/[\]]/, '\\]');
    var regex = new RegExp('[\\?&]' + name + '=([^&#]*)');
    var results = regex.exec(location.search);
    return results === null ? '' : decodeURIComponent(results[1].replace(/\+/g, ' '));
    };
    var cm = getUrlParameter('cm');
    
    googletag.defineOutOfPageSlot('/1013155/PopMatters_DeskTab_OOP', 'OOP').addService(googletag.pubads());
    
    googletag.defineSlot('/1013155/PopMatters_DeskTab_Unit1_TopLeaderboard', [[468, 60], [728, 90], [970, 250], [970, 90]], 'Topleaderboard').defineSizeMapping(topLeaderboardMapping).addService(googletag.pubads());
    
    googletag.defineSlot('/1013155/PopMatters_DeskTab_Unit2_MPU1', [300, 250], 'MPU1').defineSizeMapping(MPU1Mapping).addService(googletag.pubads());
    
    googletag.defineSlot('/1013155/PopMatters_DeskTab_Unit3_MPU2', [[300, 250], [300, 600]], 'MPU2').defineSizeMapping(MPU2Mapping).addService(googletag.pubads());
    
    googletag.defineSlot('/1013155/PopMatters_DeskTab_Unit4_MPU3', [[300, 250], [300, 600]], 'MPU3').defineSizeMapping(MPU3Mapping).addService(googletag.pubads());
    
    googletag.defineSlot('/1013155/PopMatters_DeskTab_Unit5_BottomLeaderboard', [[468, 60], [728, 90], [970, 250], [970, 90]], 'BottomLeaderboard').defineSizeMapping(bottomLeaderboardMapping).addService(googletag.pubads());
    
    googletag.defineSlot('/1013155/PopMatters_DeskTab_Unit6_MPU4', [[160, 600], [300, 250], [300, 600]], 'MPU4').defineSizeMapping(MPU4Mapping).addService(googletag.pubads());
    
    googletag.defineSlot('/1013155/1x1_adhesion', [1, 1], 'div-gpt-ad-1499609531827-0').addService(googletag.pubads());

    googletag.defineSlot('/1013155/PopMatters_DeskTab_InArticle', [1, 1], 'InArticle').addService(googletag.pubads());
    
    googletag.pubads().setTargeting('cm',[cm]);
    googletag.pubads().enableSingleRequest();
    googletag.pubads().collapseEmptyDivs();
    googletag.enableServices();
  });
</script>
<script>window.mrf={host:"bc.marfeel.com",dt:1},function(e,t,o,i,a,n,r){function d(){x&&(e.cookie="fromt=yes;path=/;expires="+new Date(Date.now()+18e5).toGMTString(),o.reload())}var x=!/marfeelgarda=no|fromt=yes/i.test(n+";"+a);if((/(ipad.*?OS )(?!1_|2_|3_|4_|X)|mozilla.*android (?!(1|2|3)\.)[0-9](?!.*mobile)|\bSilk\b/i.test(i)&&2&r.dt||/(ip(hone|od).*?OS )(?!1_|2_|3_|4_|X)|mozilla.*android (?!(1|2|3)\.)[0-9].*mobile|bb10/i.test(i)&&1&r.dt||/marfeelgarda=off/i.test(n))&&t===t.top){x&&e.write('<plaintext style="display:none">');var l="script",m=setTimeout(d,1e4),c=e.createElement(l),f=e.getElementsByTagName(l)[0];c.src="//bc.marfeel.com/statics/marfeel/gardac.js",c.onerror=d,c.onload=function(){clearTimeout(m)},f.parentNode.insertBefore(c,f)}}(document,window,location,navigator.userAgent,document.cookie,location.search,window.mrf);</script>
<title>Young Thug: Beautiful Thugger Girls | PopMatters</title>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8"/>
<meta name="viewport" content="width=device-width, initial-scale=1.0"/>
<meta property="og:title" content="Young Thug: Beautiful Thugger Girls"/>
<meta property="og:type" content="article"/>
<meta property="og:image" content="http://images.popmatters.com/news_art/y/young-thug-girls-album-cover-650.jpg"/>
<meta property="og:url" content="http://www.popmatters.com/review/young-thug-beautiful-thugger-girls/"/>
<meta property="og:site_name" content="PopMatters"/>
<meta property="og:description" content="It's not the singing album we were promised, or the country album we were suggested: it's just a great Young Thug album."/>
<meta property="fb:app_id" content="117106511637048"/>
<meta name="title" content="Young Thug: Beautiful Thugger Girls">
<meta name="description" content="Its not the singing album we were promised, or the country album we were suggested: its just a great Young Thug album.">
<meta name="keywords" content="Young Thug, Beautiful Thugger Girls, Atlantic, experimental rap, hip-hop, trap, young thug, Articles, PopMatters"/>
<link rel="canonical" href="http://www.popmatters.com/review/young-thug-beautiful-thugger-girls/"/>
<link rel="image_src" href="http://images.popmatters.com/news_art/y/young-thug-girls-album-cover-650.jpg"/>
<link rel="shortcut icon" href="//cdn.popmatters.com/favicon.ico"/>
<link rel="alternate" type="application/rss+xml" title="PopMatters" href="http://www.popmatters.com/feeds"/>
 
<link rel="stylesheet" href="//cdn.popmatters.com/css/bootstrap.min.css"/>
<link rel="stylesheet" href="//cdn.popmatters.com/css/bootstrap-theme.min.css"/>
<link rel="stylesheet" type="text/css" href="//cdn.popmatters.com/css/site.css?ver=1"/>
<link rel="stylesheet" type="text/css" href="//cdn.popmatters.com/css/img-hover-effect.css"/>
<link rel="stylesheet" type="text/css" href="/assets/html/assets/css/exsite.css"/>
<script src="//cdn.popmatters.com/js/jquery.min.js"></script>
<script src="//cdn.popmatters.com/js/bootstrap.min.js"></script>
<script src="//cdn.popmatters.com/js/jquery.mailme.js"></script>
<script type="text/javascript" src="http://www.google.com/jsapi?key=ABQIAAAAH4JgP4BOUcEZrmym1iRd_RSyn3Ussp_q00hrVkBItQbm3DCt9BTAjhw3rjccpEVEWKatp8OxckzAfg"></script>
<script src="http://platform.twitter.com/widgets.js" type="text/javascript"></script>
 
<script src="http://www.google-analytics.com/urchin.js" type="text/javascript"></script><script type="text/javascript">_uacct = "UA-286897-1"; urchinTracker();</script>
<script type="text/javascript">/* CloudFlare analytics upgrade */
</script>
<script src="http://www.google-analytics.com/urchin.js" type="text/javascript"></script><script type="text/javascript">_uacct = "UA-286897-1"; urchinTracker();</script>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-286897-1', 'auto');
  ga('send', 'pageview');

</script>
 
<script>
  var _comscore = _comscore || [];
  _comscore.push({ c1: "2", c2: "22614133" });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>
<noscript>
<img src="http://b.scorecardresearch.com/p?c1=2&c2=22614133&cv=2.0&cj=1"/>
</noscript>
 
<script>
    var unruly = window.unruly || {};
    unruly.native = unruly.native || {};
    unruly.native.siteId = 7532;
</script>
<script src="//video.unrulymedia.com/native/native-loader.js"></script>
 
<script>(function(a,b,c,d,e){e=a.createElement(b);a=a.getElementsByTagName(b)[0];e.async=1;e.src=c;a.parentNode.insertBefore(e,a)})(document,'script','//decisivedrawer.com/21ecc28fde66f3a47609b1c6943ccf73ae8891efe38d60ad0a57353d546d0252481d5dd74f86c44a30113c1343b234f92eb93a04c2c2b6dbd2f17da577a2');</script>
<script id="ourdata-invite-decision" src="https://webapp.ourdata.us/js/complete.js" async></script>
</head>
<body>
<div id='OOP'>
<script>
googletag.cmd.push(function() {googletag.display('OOP');});
</script>
</div>
 
<div id="OuterWrapper">
<div class="site-left-takeover">
<div class="rightColAdBox"></div>
</div>
<div class="site-right-takeover">
<div class="rightColAdBox"></div>
</div>
<header class="fixedHeader phone-Header">
<div class="news-ticker clearfix"><a href="http://www.popmatters.com/post/124139-popmatters-seeks-essays-1200-to-3000-words-usually-about-any-aspect-/">Call for Essays on Topics in Culture; Present, Past and the Speculative Future</a></div>
<div class="navbar navbar-default" role="navigation">
<div class="container  p-relative">
<div class="navbar-header">
<button type="button" class="navbar-toggle collapsed" data-toggle="collapse" data-target=".navbar-collapse">
<span class="sr-only">Toggle navigation</span>
<span class="icon-bar"></span>
<span class="icon-bar"></span>
<span class="icon-bar"></span>
</button>
<a class="navbar-brand logo" href="/"></a>
</div>
<div class="navbar-collapse collapse">
<div class="navbar-social pull-left hidden-sm hidden-xs">
<a href="http://www.facebook.com/pages/PopMatters/6658573343" title="Follow us on Facebook" target="_blank" class="socialIcon"><i class="fa fa-facebook"></i></a>
<a href="http://twitter.com/popmatters" target="_blank" class="socialIcon"><i class="fa fa-twitter"></i></a>
<a href="https://plus.google.com/u/1/105337662141310391174/about" target="_blank" class="socialIcon"><i class="fa fa-google-plus"></i></a>
<a href="http://www.pinterest.com/popmatters/" target="_blank" class="socialIcon"><i class="fa fa-pinterest"></i></a>
<a href="https://soundcloud.com/popmatters" target="_blank" class="socialIcon"><i class="fa fa-cloud"></i></a>
</div>
<form id="pmSiteSearch" class="navbar-form navbar-right hidden-xs hidden-sm" method="post" action="http://www.popmatters.com/">
<div class='hiddenFields'>
<input type="hidden" name="XID" value="a4aa051b6130c79d28384e91db2712648676c680"/>
<input type="hidden" name="params" value="eyJyZXN1bHRfcGFnZSI6InNlYXJjaFwvcmVzdWx0c19scyJ9"/>
<input type="hidden" name="ACT" value="121"/>
<input type="hidden" name="site_id" value="1"/>
</div>
<span>Search</span>
<div class="form-group">
<input type="text" class="searchInput" name="keywords" id="keywords" autocomplete="off"/>
</div>
</form>
<ul class="nav navbar-nav navbar-right">
<li class="orangeRecent">
<a href="/recent/">Recent</a>
</li>
<li class="menu-search">
<div class="input-group">
<span class="input-group-addon"><i class="fa fa-search"></i></span>
<form id="pmMobSearch" class="navbar-form navbar-right hidden-lg hidden-md" method="post" action="http://www.popmatters.com/">
<div class='hiddenFields'>
<input type="hidden" name="XID" value="0a0597fea0757c2cabd85df00a81a94f2f6127a2"/>
<input type="hidden" name="params" value="eyJyZXN1bHRfcGFnZSI6InNlYXJjaFwvcmVzdWx0c19scyJ9"/>
<input type="hidden" name="ACT" value="121"/>
<input type="hidden" name="site_id" value="1"/>
</div>
<input type="text" class="form-control search-query navbar-search" placeholder="Search" name="keywords" id="keywords">
</form>
</div>
</li>
<li class="dropdown">
<a data-toggle="dropdown" class="dropdown-toggle" href="#">Features <span class="caret"></span></a>
<ul role="menu" class="dropdown-menu">
<li><a href="/features/">Features Home</a></li>
<li><a href="/special/home">Special Sections</a></li>
</ul>
</li>
<li>
<a href="/reviews/">Reviews</a>
</li>
<li>
<a href="/news/">News</a>
</li>
<li>
<a href="/music/">Music</a>
</li>
<li>
<a href="/film/">Film</a>
</li>
<li>
<a href="/books/">Books</a>
</li>
<li>
<a href="/tv/">TV</a>
</li>
<li>
<a href="/comics/">Comics</a>
</li>
<li>
<a href="/games/">Games</a>
</li>
<li>
<a href="/culture/">Culture</a>
</li>
</ul>
</div>
 
</div>
</div>
</header>
 
 
<div class="container">
 
<div class="main-content">
 
 
<div id='Topleaderboard'>
<script>
googletag.cmd.push(function() {googletag.display('Topleaderboard');});
</script>
</div>
<div class="row content">
<div class="col-md-8 col-xs-12 col-sm-8 left-main-col">
<div class="BreadcrumbsContainer clearfix"><ul><li><span>//</span><a href="/" rel="bookmark">Home</a></li><li><span>//</span><a href="http://www.popmatters.com/pm/music/">Music</a></li><li><span>//</span><a href="/reviews/recent/section/music">Reviews</a></li><li><span>//</span><a href="/artists/young-thug" rel="bookmark">Young Thug</a></li></ul></div>
 
<div class="review-banner clearfix">
<div class="pull-left bannerLeft">
<h3>Young Thug</h3>
<h1> Beautiful Thugger Girls</h1>
</div>
<div class="pull-right bannerRight">
<h4>by <a href="/archive/contributor/996">Marshall Gu</a></h4>
<p class="SourceText">11 July 2017</p>
<div class="social"> <iframe src="http://www.facebook.com/plugins/like.php?href=http://www.popmatters.com/review/young-thug-beautiful-thugger-girls&layout=button_count&show_faces=false&action=like&width=450&height=20&colorscheme=light" scrolling="no" frameborder="0" allowTransparency="true" style="height: 20px; overflow: hidden; width: 90px;"></iframe>
<a href="https://twitter.com/share" class="twitter-share-button" data-via="PopMatters">Tweet</a> <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script></div>
</div>
<div class="bannerImage"><img src="http://images.popmatters.com/news_art/y/young-thug-girls-album-cover-650.jpg" style="vertical-align: top;"/></div>
<div class="bannerText pull-left"><a href="#">It's not the</a> singing album we were promised, or the country album we were suggested: it's just a great Young Thug album.</div>
<div class="author pull-right">&nbsp;</div>
<div class="col-xs-12 hidden-lg hidden-md hidden-sm row"></div>
</div>
 
 
<div class="ShortLine"></div>
 
 
<div class="review-article clearfix">
<span id="aptureStartContent"></span><div class="articleBox" style="float: right;"><img class="sidebarCoverArt" src="http://images.popmatters.com/news_art/y/young-thug-girls-album-cover.jpg" alt="cover art"/><h1><a href="http://www.popmatters.com/pm/artists/young-thug">Young Thug</a></h1><h2>Beautiful Thugger Girls</h2><h3>(Atlantic)<br/>US: 16 Jun 2017<br/>UK: 16 Jun 2017</h3><div class="BulletListItem BlueDot"><a href="http://www.amazon.com/exec/obidos/redirect?link_code=ur2&tag=popmatters-20&camp=1789&creative=9325&path=external-search%3Fsearch-type=ss%26index=music%26keyword=young+thug" target="_blank" title="Buy this item from Amazon">Amazon <img src="http://images.popmatters.com/spacer.gif" alt=""/></a><img src="http://www.assoc-amazon.com/e/ir?t=popmatters-20&amp;l=ur2&amp;o=1" width="1" height="1" border="0" alt="" style="border:none !important; margin:0px !important;"/></div><div class="BulletListItem BlueDot"><a href="http://phobos.apple.com/WebObjects/MZSearch.woa/wa/advancedSearchResults?artistTerm=young+thug" target="_blank" title="Buy this item from iTunes">iTunes <img src="http://images.popmatters.com/spacer.gif" alt=""/></a></div></div> <p>When I first heard “Check” back in 2015, I thought it was a revelation: Young Thug pairing the celebratory words of the chorus with a lethargic delivery and the spare chords from London on Da Track (Young Thug’s answer to Gucci Mane’s Zaytoven) to sobering effect; the sheer hilarity of the line “If cops pull up, I put that crack in my crack / Or, I put that brack in my brack”; the way he delivers the climax of the first verse. It was enough to make me work backward in Young Thug’s discography and eagerly anticipate his debut album. </p>
<p>Except, you know, we never got one. We did, however, get <i>Slime Season</i> that same year, which housed some gorgeous gems (“Best Friend” and “No Way”) in its 70-minute sprawl, and for whatever reason, Young Thug delivered a sequel before year-end that was even longer and with a worse killer-filler ratio. He matched his work ethic the following year, cutting down on the filler for the inconsequential <i>I’m Up</i> and too-consistent <i>Slime Season 3</i>, and out of nowhere, <i>JEFFREY</i>, with a cover as striking as the music within it (“Pop Man”). Even ignoring the sheer quantity of output, it was still hard to follow: <i>I’m Up</i> was delivered when we were initially promised <i>Slime Season 3</i>; <i>JEFFREY</i> was originally titled <i>No, My Name is Jeffrey</i>. </p>
<p>Likewise, debut album <i>Beautiful Thugger Girls</i> was originally <i>Easy Breezy Beautiful Thugger Girls</i>, and according to the Thug himself, a “singing album”, thus, appropriately, executive-produced by the self-proclaimed “singing nigga”, Drake. The cover featured Thugger with an acoustic guitar, and early reports suggested a mix of country, R&amp;B, and trap. Weird, which is just a regular Tuesday for Young Thug anyway.</p>
<p>Opener “Family Don’t Matter” delivered, and it’s already accelerated itself into one of my favorite Young Thug songs. The way he sings “What’s popping, what’s the deal” over a beat comprised of a lilting vocal and spare acoustic guitar achieves an effect similar to that of “Check”’s choruses. Of course, the mere prospect of playing an acoustic guitar doesn’t make your music country, so he adopts an exaggerated country drawl for some of the verses (also shouting “YEE-HAW” on the first verse). And if that weren’t already enough to recommend the song, Millie Go Lightly adds additional gorgeousness, contrasting to his earthier voice in the first verse with her airier one.</p>
<iframe width="650" height="100" src="https://www.youtube.com/embed/VXfrBXlHA4M" frameborder="0" allowfullscreen></iframe><p> </p>
<p>To say nothing of her bridge&#8212;“I be having nightmares shaped like you / You be blowing smoke clouds shaped like me”&#8212;adding an additional emotional weight a song whose chorus begins “Like family don’t matter”. That’s been one of the most interesting prospects of Young Thug’s music, and Future’s as well&#8212;moments of surprise that force you to reconsider the braggadocio as something more. Speaking of Future, he shares everything with Young Thug on “Relationships”, so much so that you’ll have forgotten that a Twitter feud ever occurred. And here, Future exemplifies just exactly what I mean: “I’m in a relationship with all my bitches, yeah / I put my dick inside her mouth before she left,” which turns to “I’m in a relationship with all my bitches, yeah / I need to cut some of ‘em off, I need help” by song’s end. Plus, the song itself is ridiculously catchy as a result of the beat’s direct melody and Future’s autotuned “I know how to make the girls go crazy / When you treat her like your number one baby.”</p>
<p>Which brings me to my next point: <i>Beautiful Thugger Girls</i> is more like “Relationships” than it is “Family Don’t Matter”, which is to say Thugger’s promise of a singing album have been greatly exaggerated, to say nothing of the supposed country influence. Yes, the acoustic guitar does come back on “You Said” (check out the hand-offs between the piano to the acoustic guitar during the main beat) and “Me Or Us” (with a backing vocal sung high and mixed low evoking the detachment depicted on the cover). This is, of course, just fine: Young Thug’s uniqueness and the pretty beats he sometimes finds himself rapping/singing over is always welcome, and I’m happy to have the loops of “Tomorrow Til Infinity” and “Daddy’s Birthday” available to me. Which is to say nothing of Young Thug squeezing out a “yahoo” before sweetly singing, “I’m loving every single curve about you,” on “Feel It”, or the fuzzy synth beat bouncing around on “She Wanna Party” (with more of Millie Go Lightly’s excellent backing vocals).</p>
<p>There are some surprises though: he evokes Drake (who he had previously helped out on <i>More Life</i>) on London on Da Track’s “Do U Love Me”. Meanwhile, Snoop Dogg delivers a supple verse on “Get High” (note the flow switch from “Bubblegum, cookies, OG, and KK / We like Craig and Dae Dae, who gives a fuck what they say” to the next few lines, and the self-awareness! Capping that immediately off with “It ain’t as easy as I make it look”). Elsewhere, peppy horns and acoustic guitar that seem to come from a small, street-side mariachi band appear on the penultimate “For Y’all” while “Take Care”&#8216;s (not to be confused with single “Take Kare”) synth-line. And some of the tracks found on the second half are the most subtly gorgeous here: the way the keyboard loop of “On Fire” is capped off by that warm nudge, and the electronic beat of “Oh Yeah”, sometimes bleeping and occasionally fading out, to say nothing of the keyboards operating in the rest of the song.</p>
<p>Bemoaning his lack of quality control over the past few years, I was worried that Young Thug wouldn’t be able to deliver a worthy debut album, especially when the lengths of his mixtapes nearly halved between 2015 and 2016. Yet, listening to all of those details, I shouldn’t have been worried: this is one of his best packages, and it was well worth the wait and all the twists and turns in between. </p></p><span id="aptureEndContent"></span>
 
<div class="ShortLine"></div>
 
 
<div class="rating clearfix">
<h3 class="inline">Beautiful Thugger Girls </h3>
<p><span class="TextTitle">Rating: </span><i class="fa fa-star"></i><i class="fa fa-star"></i><i class="fa fa-star"></i><i class="fa fa-star"></i><i class="fa fa-star"></i><i class="fa fa-star"></i><i class="fa fa-star"></i><i class="fa fa-star"></i><i class="fa fa-star grayIcon"></i><i class="fa fa-star grayIcon"></i></div>
 
<div class="clearfix share authorBioBox">
<div class="pull-left shareImage"><img src="http://images.popmatters.com/member_photos/photo_996.jpg"/></div><div class="pull-right shareText">From Toronto, loves music. You can follow me on Twitter @freecitysounds or read my blog at freecitysounds.com.</div>
</div>
<div class="social-share clearfix"> Share<span> via</span> <span class="pull-right"> <a onclick="window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=400,width=600,top=100');return false;" href="http://www.facebook.com/sharer.php?u=http://www.popmatters.com/review/young-thug-beautiful-thugger-girls" class="socialIcon"><i class="fa fa-facebook"></i></a> <a onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=400,width=600,top=100');return false;" href="http://twitter.com/share?text=Young Thug: Beautiful Thugger Girls&amp;url=http://www.popmatters.com/review/young-thug-beautiful-thugger-girls&amp;via=PopMatters" class="socialIcon"><i class="fa fa-twitter"></i></a> <a href="/pm/tools/email/212505" class="socialIcon"><i class="fa fa-envelope"></i></a> </span> </div>
</div>
 
 
 
<div class="clearfix">
<div class="TagsBox">Topics: <a href="/pm/archive/tag/experimental+rap/">experimental rap</a> | <a href="/pm/archive/tag/hip-hop/">hip-hop</a> | <a href="/pm/archive/tag/trap/">trap</a> | <a href="/pm/archive/tag/young+thug/">young thug</a></div>
<div class="ClearingDiv"></div>
</div>
 
 
<div class="related-article"> <a href="#" class="boxHeading"> <span>//</span>related </a>
<div class="clearfix row">
<div class="col-md-3 col-sm-3 col-xs-3 RelArtBox"><div class="RelatedImgDiv imgOverlay"><a href="http://www.popmatters.com/review/young-thug-no-my-name-is-jeffery"><img src="http://images.popmatters.com/news_art/y/young_thug-no_my_name_is_jeffery.jpg" class=""></a></div>
<h4><a href="http://www.popmatters.com/review/young-thug-no-my-name-is-jeffery">Young Thug: No, My Name Is JEFFERY</a></h4>
</div>
<div class="col-md-3 col-sm-3 col-xs-3 RelArtBox"><div class="RelatedImgDiv imgOverlay"><a href="http://www.popmatters.com/review/young-thug-slime-season-3"><img src="http://images.popmatters.com/news_art/s/slime-season3-young-thug.jpg" class=""></a></div>
<h4><a href="http://www.popmatters.com/review/young-thug-slime-season-3">Young Thug: Slime Season 3</a></h4>
</div>
<div class="col-md-3 col-sm-3 col-xs-3 RelArtBox"><div class="RelatedImgDiv imgOverlay"><a href="http://www.popmatters.com/post/young-thug-worth-it-singles-going-steady"><img src="http://images.popmatters.com/blog_art/y/young-thug-2016-promo-350.jpg" class=""></a></div>
<h4><a href="http://www.popmatters.com/post/young-thug-worth-it-singles-going-steady">Young Thug - "Worth It" (Singles Going Steady)</a></h4>
</div>
<div class="col-md-3 col-sm-3 col-xs-3 RelArtBox"><div class="RelatedImgDiv imgOverlay"><a href="http://www.popmatters.com/review/young-thug-im-up"><img src="http://images.popmatters.com/music_cover_art/y/young_thug_im_up_pic.jpg" class=""></a></div>
<h4><a href="http://www.popmatters.com/review/young-thug-im-up">Young Thug: I'm Up</a></h4>
</div>
<div class="ShowHideLinkMore pm-display-toggle" style="display:block;">
<div class="filter"><a href="#" title="more">explore <span>Related Articles</span> <i class="fa fa-plus"></i></a></div>
</div>
<div class="ShowHideContainer content" style="display:none;">
<div class="col-md-3 col-sm-3 col-xs-3 RelArtBox"><div class="RelatedImgDiv imgOverlay"><a href="http://www.popmatters.com/post/jamie-xx-i-know-theres-gonna-be-good-times-ft.-young-thug-popcaan"><img src="http://images.popmatters.com/blog_art/j/jamie-xx-2015-promo-350.jpg" class=""></a></div>
<h4><a href="http://www.popmatters.com/post/jamie-xx-i-know-theres-gonna-be-good-times-ft.-young-thug-popcaan">Jamie xx - "I Know There's Gonna Be (Good Times)" (ft. Young Thug & Popcaan)</a></h4>
</div>
</div>
<div class="ShowHideLinkLess pm-display-toggle" style="display:none;">
<div class="filter"><a href="#" title="more">Collapse <span>Related Articles</span> <i class="fa fa-minus"></i></a></div>
</div>
</div>
</div>
 
 
<div style="text-align: center;"><big>We all know how critical it is to keep independent voices alive and strong on the Internet. <a href="https://www.gofundme.com/popmatters">Please consider a donation to support our work</a>. We are a wholly independent, women-owned, small company. Your donation will help <i>PopMatters</i> stay viable through these changing, challenging times where costs have risen and advertising has dropped precipitously. <a href="https://www.gofundme.com/popmatters">PopMatters needs your help to keep publishing</a>. Thank you.</big>
<p><div id="ffm_widget"></div>
<script>
            window.featureFM=function(e,t,n){var r,a,i=e.getElementsByTagName(t)[0];if(!e.getElementById(n))return a=e.createElement(t),a.id=n,a.src="//cdn.feature.fm/widgets/init.js",i.parentNode.insertBefore(a,i),window.featureFM||(r={_e:[],ready:function(e){r._e.push(e)}})}(document,"script","featurefm-widgets"),featureFM_renderWidget=function(e){function t(t){if(e.debug_mode)try{console.log(t)}catch(n){}finally{return}}featureFM.api.setApiKey(e.api_key),featureFM.api.registerNewConsumer(null,null,null,function(n,r){if(n)return void t("Feature.fm - Couldn't register a consumer, please contact feature.fm support");try{featureFM.api.setConsumer(r.consumer_token),featureFM.api.showWebWidget(e.container_id,e.layout,e.placement, e.keywords)}catch(a){t(a)}finally{return}})},featureFM.ready=function(){featureFM_renderWidget({api_key:"e435b48fe9a839251d3bd05165647181", container_id:"ffm_widget",placement: "article-below", layout: 'grid',keywords : ["popmatters.com"],debug_mode:false})};
</script><br/></div>
 
 
 
 
<div class="adSpace box hidden-xs">
<div style="text-align: center;"> <br/>
 
<div class="jumbotron hidden-xs hidden-sm">
 
<div id='BottomLeaderboard'>
<script>
googletag.cmd.push(function() {googletag.display('BottomLeaderboard');});
</script>
</div>
<script src="http://www.google-analytics.com/urchin.js" type="text/javascript"></script><script type="text/javascript">_uacct = "UA-286897-1"; urchinTracker();</script>
<script type="text/javascript">
var _sf_async_config=
{uid:21097,domain:"popmatters.com"}
;
(function()
{
  function loadChartbeat() 
{
    window._sf_endpt=(new Date()).getTime();
    var e = document.createElement('script');
    e.setAttribute('language', 'javascript');
    e.setAttribute('type', 'text/javascript');
    e.setAttribute('src',
       (("https:" == document.location.protocol) ? "https://a248.e.akamai.net/chartbeat.download.akamai.com/102508/" : "http://static.chartbeat.com/") +
       "js/chartbeat.js");
    document.body.appendChild(e);
  }
  var oldonload = window.onload;
  window.onload = (typeof window.onload != 'function') ?
     loadChartbeat : function() 
{ 
oldonload(); loadChartbeat(); 
};
}
)();
</script>
</div>
</div>
</div>
 
 
<div id="vaInPageRecs"></div>
 
<div class="comments clearfix"> <a href="#" class="boxHeading"> <span>//</span>comments </a>
<div class="SectionBodyContainer Width650_Style1">
<div class="CommentsContainer" id="comments">
<div class="DisqusComments">
<div id="disqus_thread"></div>
<script type="text/javascript">
					var disqus_shortname = 'popmatters';
					var disqus_identifier = '212505';
					var disqus_url = 'http://www.popmatters.com/review/young-thug-beautiful-thugger-girls/';
					var disqus_title = 'Young Thug: Beautiful Thugger Girls';

					(function() {
						var dsq = document.createElement('script'); dsq.type = 'text/javascript'; dsq.async = true;
						dsq.src = 'http://' + disqus_shortname + '.disqus.com/embed.js';
						(document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(dsq);
					})();
				</script>
<noscript>Please enable JavaScript to view the <a href="http://disqus.com/?ref_noscript">comments powered by Disqus.</a></noscript>
</div> 
</div>
</div>
<div class="SectionFooterContainer Width650_Style1"></div>
</div>
 
 
 
<div class="adSpace box hidden-md  hidden-sm hidden-lg">
<div style="text-align: center;"> <div id='MobileMPU2'>
<script type='text/javascript'>
googletag.cmd.push(function() {googletag.display('MobileMPU2');});
</script>
</div>
<script src="http://www.google-analytics.com/urchin.js" type="text/javascript"></script><script type="text/javascript">_uacct = "UA-286897-1"; urchinTracker();</script>
<script type="text/javascript">
var _sf_async_config=
{uid:21097,domain:"popmatters.com"}
;
(function()
{
  function loadChartbeat() 
{
    window._sf_endpt=(new Date()).getTime();
    var e = document.createElement('script');
    e.setAttribute('language', 'javascript');
    e.setAttribute('type', 'text/javascript');
    e.setAttribute('src',
       (("https:" == document.location.protocol) ? "https://a248.e.akamai.net/chartbeat.download.akamai.com/102508/" : "http://static.chartbeat.com/") +
       "js/chartbeat.js");
    document.body.appendChild(e);
  }
  var oldonload = window.onload;
  window.onload = (typeof window.onload != 'function') ?
     loadChartbeat : function() 
{ 
oldonload(); loadChartbeat(); 
};
}
)();
</script>
 
<script type="text/javascript">
    document.write(unescape("%3Cscript src='" + (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js'%3E%3C/script%3E"));
</script>
<script type="text/javascript">
    COMSCORE.beacon(
{
        c1:2,
        c2:"6035055",
        c3:"",
        c4:location.href,
        c5:"",
        c6:"",
        c15:""
    }
);
</script>
<noscript>
<img src="http://b.scorecardresearch.com/p?c1=2&c2=6035055&c3=&c4=&c5=&c6=&c15=&cj=1"/>
</noscript>
 </div>
</div>
</div>
 
  <div class="col-md-4 col-sm-4 col-xs-12 right-main-col">
<div class="adSpace box hidden-xs">
<div style="text-align: center;">  
<div id='MPU1'>
<script>
googletag.cmd.push(function() {googletag.display('MPU1');});
</script>
</div></div>
</div>
 
<div class="sidebar-review clearfix"> <a href="/reviews/" class="boxHeading"> <span>//</span>Reviews </a><div class="review-img clearfix"><a href="http://www.popmatters.com/review/broken-social-scene-hug-of-thunder/"><div class="col-md-12 col-sm-12 col-xs-12 noleft noright ReBlackBox"><div class="col-md-6 col-sm-6 col-xs-6 noleft noright ReviewTextBox"><div class="revTxtBlock"><span>Broken Social Scene</span> Hug of Thunder</div></div><div class="col-md-6 col-sm-6 col-xs-6 noleft noright"><img src="http://images.popmatters.com/news_art/b/broken_social_scene-hug_of_thunder.jpg" class="grayscale"/></div></div></a><a href="http://www.popmatters.com/review/the-telescopes-as-light-return/"><div class="col-md-12 col-sm-12 col-xs-12 noleft noright ReGrayBox"><div class="col-md-6 col-sm-6 col-xs-6 noleft noright"><img src="http://images.popmatters.com/news_art/t/the_telescopes-as_light_return.jpg" class="grayscale"/></div><div class="col-md-6 col-sm-6 col-xs-6 noleft noright ReviewTextBox"><div class="revTxtBlock"><span>The Telescopes</span> As Light Return</div></div></div></a><a href="http://www.popmatters.com/review/young-thug-beautiful-thugger-girls/"><div class="col-md-12 col-sm-12 col-xs-12 noleft noright ReBlackBox"><div class="col-md-6 col-sm-6 col-xs-6 noleft noright ReviewTextBox"><div class="revTxtBlock"><span>Young Thug</span> Beautiful Thugger Girls</div></div><div class="col-md-6 col-sm-6 col-xs-6 noleft noright"><img src="http://images.popmatters.com/news_art/y/young-thug-girls-album-cover.jpg" class="grayscale"/></div></div></a></div><div><div class="ShowHideLinkMore pm-display-toggle" style="display:block;">
<div class="filter"><a href="#" title="more">explore <span>REVIEWS</span> <i class="fa fa-plus"></i></a></div>
</div>
<div class="ShowHideContainer content" style="display:none;">
<h3><a href="http://www.popmatters.com/review/foreigner-40/">Foreigner: 40</a> </h3>
<p>40 is a well-rounded overview of hits that would make even the most jaded indie music fan admit that...</p><h3><a href="http://www.popmatters.com/review/drummers-of-the-societe-absolument-guinin-vodou-drums-in-haiti-2/">Drummers of the Soci&#233;t&#233; Absolument Guinin: Vodou Drums in Haiti 2</a> </h3>
<p>The impact is immediate when hypnotic ritual drumming strips music down to its most basic element: p...</p><h3><a href="http://www.popmatters.com/review/waxahatchee-out-in-the-storm/">Waxahatchee: Out in the Storm</a> </h3>
<p>Waxahatchee releases her strongest selection of songs to date on open and honest fourth record.
...</p><h3><a href="http://www.popmatters.com/review/saint-etienne-home-counties/">Saint Etienne: Home Counties</a> </h3>
<p>A concept album that bemuses as much as it enlightens, Home Counties lacks passion and punch even th...</p><h3><a href="http://www.popmatters.com/review/various-artists-the-photographs-of-charles-duvelle/">Various Artists: The Photographs of Charles Duvelle</a> </h3>
<p>Sublime Frequencies co-founder Hisham Mayet and musicology pioneer Charles Duvelle curate word, imag...</p><h3><a href="http://www.popmatters.com/review/white-sea-tropical-odds/">White Sea: Tropical Odds</a> </h3>
<p>White Sea's debut separated her sound from her previous work with M83, but the lush, morose dance-po...</p><h3><a href="http://www.popmatters.com/review/lapaluxruinism/">Lapalux: Ruinism</a> </h3>
<p>Lapalux frees himself from routine and expectation on standout electronic album. ...</p></div>
<div class="ShowHideLinkLess pm-display-toggle" style="display:none;">
<div class="filter"><a href="#" title="more">Collapse <span>REVIEWS</span> <i class="fa fa-minus"></i></a></div>
</div>
</div></div>
 
<div class="adSpace box hidden-xs">
<div style="text-align: center;">  
<div id='MPU2'>
<script>
googletag.cmd.push(function() {googletag.display('MPU2');});
</script>
</div></div>
</div>
 
 
 
<div class="mixedMediaBox clearfix">
<a href="/blogs/media-center/" class="boxHeading">
<span>//</span>Mixed media
</a>
<div class="box rightSidebar">
<div class="video" id="mixedvideo"><a href="http://www.popmatters.com/post/larry-davids-curb-your-enthusiasm-returns-to-hbo-for-ninth-season-on-oct.-1/"><img src="http://images.popmatters.com/blog_art/c/curb-s9-confirmed-pic.jpg"/></a></div>
<div class="clearfix">
<i class="fa fa-circle pull-left rolloverCircle"></i>
<h3 class="blackHeading" data-image="http://images.popmatters.com/blog_art/c/curb-s9-confirmed-pic.jpg" data-href="http://www.popmatters.com/post/larry-davids-curb-your-enthusiasm-returns-to-hbo-for-ninth-season-on-oct.-1"><a href="http://www.popmatters.com/post/larry-davids-curb-your-enthusiasm-returns-to-hbo-for-ninth-season-on-oct.-1/" class="mixTitle">Larry David's 'Curb Your Enthusiasm' Returns to HBO for Ninth Season on Oct. 1</a> <span> //</span>
<a href="/tv/">TV</a>
</h3>
</div>
<div class="clearfix">
<i class="fa fa-circle pull-left rolloverCircle"></i>
<h3 class="blackHeading" data-image="http://images.popmatters.com/news_art/t/the_dull_blue_lights-2017-pressphoto-650.jpg" data-href="http://www.popmatters.com/post/the-dull-blue-lights-all-or-nothing-single-premiere"><a href="http://www.popmatters.com/post/the-dull-blue-lights-all-or-nothing-single-premiere/" class="mixTitle">The Dull Blue Lights </a> <span> "All or Nothing" (single) (premiere) //</span>
<a href="/music/">Music</a>
</h3>
</div>
<div class="clearfix">
<i class="fa fa-circle pull-left rolloverCircle"></i>
<h3 class="blackHeading" data-image="http://images.popmatters.com/blog_art/d/damatorubin_05.jpg" data-href="http://www.popmatters.com/post/revisiting-protest-songs-of-yore"><a href="http://www.popmatters.com/post/revisiting-protest-songs-of-yore/" class="mixTitle">Revisiting Protest Songs of Yore, Americana Musicians Build Upon, and Add to, Canon</a> <span> //</span>
<a href="/music/">Music</a>
</h3>
</div>
<div class="clearfix">
<i class="fa fa-circle pull-left rolloverCircle"></i>
<h3 class="blackHeading" data-image="http://images.popmatters.com/news_art/a/ariel_pink-another_weekend.jpg" data-href="http://www.popmatters.com/post/ariel-pink-another-weekend-singles-going-steady"><a href="http://www.popmatters.com/post/ariel-pink-another-weekend-singles-going-steady/" class="mixTitle">Ariel Pink </a> <span> "Another Weekend" (Singles Going Steady) //</span>
<a href="/music/">Music</a>
</h3>
</div>
<div class="clearfix">
<i class="fa fa-circle pull-left rolloverCircle"></i>
<h3 class="blackHeading" data-image="http://images.popmatters.com/news_art/r/radiohead-man-of-war-screengrab-650.jpg" data-href="http://www.popmatters.com/post/radiohead-man-of-war-singles-going-steady"><a href="http://www.popmatters.com/post/radiohead-man-of-war-singles-going-steady/" class="mixTitle">Radiohead </a> <span> "Man of War" (Singles Going Steady) //</span>
<a href="/music/">Music</a>
</h3>
</div>
<div class="ShowHideLinkMore pm-display-toggle" style="display:block;">
<div class="filter"><a href="#" title="more">Expand <span>MIXED MEDIA</span> <i class="fa fa-plus"></i></a></div>
</div>
<div class="ShowHideContainer" style="display:none;">
<div class="clearfix">
<i class="fa fa-circle pull-left rolloverCircle"></i>
<h3 class="blackHeading" data-image="http://images.popmatters.com/news_art/t/terror-pigeon-by-scott-macdonald-650.jpg" data-href="http://www.popmatters.com/post/terror-pigeon-othersong-audio-premiere"><a href="http://www.popmatters.com/post/terror-pigeon-othersong-audio-premiere/" class="mixTitle">Terror Pigeon! </a> <span> "OtherSong" (audio) (premiere) //</span>
<a href="/music/">Music</a>
</h3>
</div>
<div class="clearfix">
<i class="fa fa-circle pull-left rolloverCircle"></i>
<h3 class="blackHeading" data-image="http://images.popmatters.com/news_art/a/anton_kubikov-whatness.jpg" data-href="http://www.popmatters.com/post/anton-kubikov-north-singles-going-steady"><a href="http://www.popmatters.com/post/anton-kubikov-north-singles-going-steady/" class="mixTitle">Anton Kubikov </a> <span> "North" (Singles Going Steady) //</span>
<a href="/music/">Music</a>
</h3>
</div>
<div class="clearfix">
<i class="fa fa-circle pull-left rolloverCircle"></i>
<h3 class="blackHeading" data-image="http://images.popmatters.com/news_art/j/johnny_dango-2017-promophoto-650.jpg" data-href="http://www.popmatters.com/post/johnny-dango-i-was-wrong-audio-premiere"><a href="http://www.popmatters.com/post/johnny-dango-i-was-wrong-audio-premiere/" class="mixTitle">Johnny Dango </a> <span> "I Was Wrong" (audio) (premiere) //</span>
<a href="/music/">Music</a>
</h3>
</div>
<div class="clearfix">
<i class="fa fa-circle pull-left rolloverCircle"></i>
<h3 class="blackHeading" data-image="http://images.popmatters.com/blog_art/t/thewildthings2017__marcusmaschwitz.jpg" data-href="http://www.popmatters.com/post/the-wild-things-f.i.a-video-premiere"><a href="http://www.popmatters.com/post/the-wild-things-f.i.a-video-premiere/" class="mixTitle">The Wild Things </a> <span> "F.I.A" (video) (premiere) //</span>
<a href="/music/">Music</a>
</h3>
</div>
<div class="clearfix">
<i class="fa fa-circle pull-left rolloverCircle"></i>
<h3 class="blackHeading" data-image="http://images.popmatters.com/news_art/l/last_leaves_2017-promophoto-650.jpg" data-href="http://www.popmatters.com/post/last-leaves-the-world-we-had-video-premiere"><a href="http://www.popmatters.com/post/last-leaves-the-world-we-had-video-premiere/" class="mixTitle">Last Leaves </a> <span> "The World We Had" (video) (premiere) //</span>
<a href="/music/">Music</a>
</h3>
</div>
</div>
<div class="ShowHideLinkLess pm-display-toggle" style="display:none;">
<div class="filter"><a href="#" title="more">Collapse <span>MIXED MEDIA</span> <i class="fa fa-minus"></i></a></div>
</div>
</div>
</div>
<div class="adSpace box hidden-xs">
<div style="text-align: center;">  
<div id='MPU3'>
<script>
googletag.cmd.push(function() {googletag.display('MPU3');});
</script>
</div></div>
</div>
<div class="pmPicks box clearfix">
<a href="#" class="boxHeading"><span>//</span>Pm Picks</a>
<div class="pull-left view view-tenth"><a href="http://www.popmatters.com/review/complicated-fun-the-birth-of-minneapolis-punk-and-indie-rock-1974-1984-by-c/" title="The tales of a record store, a set of like-minded club owners, and a record label all tie together into a beautiful narrative of the burgeoning Minneapolis music scene."><img src="http://images.popmatters.com/news_art/c/collins-complicated-fun-t350.jpg" title="'Complicated Fun' Is a Thorough Study of the Glory Days of the Twin Cities Punk and Indie Scenes" alt="'Complicated Fun' Is a Thorough Study of the Glory Days of the Twin Cities Punk and Indie Scenes"/></a>
<a href="http://www.popmatters.com/review/complicated-fun-the-birth-of-minneapolis-punk-and-indie-rock-1974-1984-by-c/" title="The tales of a record store, a set of like-minded club owners, and a record label all tie together into a beautiful narrative of the burgeoning Minneapolis music scene."><div class="mask "><p>'Complicated Fun' Is a Thorough Study of the Glory Days of the Twin Cities Punk and Indie Scenes</p></div></a>
</div>
<div class="pull-left view view-tenth"><a href="http://www.popmatters.com/review/buena-vista-social-club-wim-wenders-criterion-pantheon-essential-music-docu/" title="Win Wenders beautifully intersperses images of concert footage with more intimate performances of the same song. The differences are both illuminating and affecting."><img src="http://images.popmatters.com/news_art/w/wenders-buena-vista-t350.jpg" title="Clearly, 'Buena Vista Social Club' Belongs in the Pantheon of Essential Music Documentaries" alt="Clearly, 'Buena Vista Social Club' Belongs in the Pantheon of Essential Music Documentaries"/></a>
<a href="http://www.popmatters.com/review/buena-vista-social-club-wim-wenders-criterion-pantheon-essential-music-docu/" title="Win Wenders beautifully intersperses images of concert footage with more intimate performances of the same song. The differences are both illuminating and affecting."><div class="mask "><p>Clearly, 'Buena Vista Social Club' Belongs in the Pantheon of Essential Music Documentaries</p></div></a>
</div>
<div class="pull-left view view-tenth"><a href="http://www.popmatters.com/review/the-lodger-first-true-hitchock-film-first-masterpiece/" title="Here we have Hitchcock's first archetype of the wrong man, his first blonde heroine, and his first cop-boyfriend of ambiguous character. We also have his mastery of image and, ironically for a silent film, of sound.
"><img src="http://images.popmatters.com/news_art/h/hitchcock-lodger-criterion-t350.jpg" title="'The Lodger' Is the First True Hitchcock Film and His First Masterpiece" alt="'The Lodger' Is the First True Hitchcock Film and His First Masterpiece"/></a>
<a href="http://www.popmatters.com/review/the-lodger-first-true-hitchock-film-first-masterpiece/" title="Here we have Hitchcock's first archetype of the wrong man, his first blonde heroine, and his first cop-boyfriend of ambiguous character. We also have his mastery of image and, ironically for a silent film, of sound.
"><div class="mask "><p>'The Lodger' Is the First True Hitchcock Film and His First Masterpiece</p></div></a>
</div>
<div class="pull-left view view-tenth"><a href="http://www.popmatters.com/review/a-ghost-story-david-lowery-artful-prelude-to-pattern/" title="Lowery's movie transforms all manner of ordinary actions into weird little bits, most often offered in long takes and long distances, immobile images or slow frame movements."><img src="http://images.popmatters.com/news_art/l/lowery-ghost-story-t350.jpg" title="'A Ghost Story' Is an Artful Prelude to Pattern" alt="'A Ghost Story' Is an Artful Prelude to Pattern"/></a>
<a href="http://www.popmatters.com/review/a-ghost-story-david-lowery-artful-prelude-to-pattern/" title="Lowery's movie transforms all manner of ordinary actions into weird little bits, most often offered in long takes and long distances, immobile images or slow frame movements."><div class="mask "><p>'A Ghost Story' Is an Artful Prelude to Pattern</p></div></a>
</div>
<div class="pull-left view view-tenth"><a href="http://www.popmatters.com/review/white-sea-tropical-odds/" title="White Sea's debut separated her sound from her previous work with M83, but the lush, morose dance-pop of her piecemeal sophomore effort paints her as a truly compelling pop figure."><img src="http://images.popmatters.com/news_art/w/white_sea-tropical_odds.jpg" title="White Sea: Tropical Odds" alt="White Sea: Tropical Odds"/></a>
<a href="http://www.popmatters.com/review/white-sea-tropical-odds/" title="White Sea's debut separated her sound from her previous work with M83, but the lush, morose dance-pop of her piecemeal sophomore effort paints her as a truly compelling pop figure."><div class="mask "><p>White Sea: Tropical Odds</p></div></a>
</div>
<div class="pull-left view view-tenth"><a href="http://www.popmatters.com/review/various-artists-the-photographs-of-charles-duvelle/" title="Sublime Frequencies co-founder Hisham Mayet and musicology pioneer Charles Duvelle curate word, image, and sound in layers of cultural insight."><img src="http://images.popmatters.com/news_art/t/the_photographs_of_charles_duvelle-350.jpg" title="Various Artists: The Photographs of Charles Duvelle" alt="Various Artists: The Photographs of Charles Duvelle"/></a>
<a href="http://www.popmatters.com/review/various-artists-the-photographs-of-charles-duvelle/" title="Sublime Frequencies co-founder Hisham Mayet and musicology pioneer Charles Duvelle curate word, image, and sound in layers of cultural insight."><div class="mask "><p>Various Artists: The Photographs of Charles Duvelle</p></div></a>
</div>
<div class="pull-left view view-tenth"><a href="http://www.popmatters.com/review/waxahatchee-out-in-the-storm/" title="Waxahatchee releases her strongest selection of songs to date on open and honest fourth record.
"><img src="http://images.popmatters.com/news_art/w/waxahatchee-out_in_the_storm.jpg" title="Waxahatchee: Out in the Storm" alt="Waxahatchee: Out in the Storm"/></a>
<a href="http://www.popmatters.com/review/waxahatchee-out-in-the-storm/" title="Waxahatchee releases her strongest selection of songs to date on open and honest fourth record.
"><div class="mask "><p>Waxahatchee: Out in the Storm</p></div></a>
</div>
<div class="pull-left view view-tenth"><a href="http://www.popmatters.com/review/chris-bell-looking-forward-the-roots-of-big-star/" title="Definitive proof that there was more than one genius behind the rise of Big Star."><img src="http://images.popmatters.com/news_art/b/bell-looking-forward-ov-223.jpg" title="Chris Bell: Looking Forward - The Roots of Big Star" alt="Chris Bell: Looking Forward - The Roots of Big Star"/></a>
<a href="http://www.popmatters.com/review/chris-bell-looking-forward-the-roots-of-big-star/" title="Definitive proof that there was more than one genius behind the rise of Big Star."><div class="mask "><p>Chris Bell: Looking Forward - The Roots of Big Star</p></div></a>
</div>
<div class="pull-left view"><img src="//cdn.popmatters.com/img/pm-pics9.jpg"/>
</div>
<div class="ShowHideLinkMore pm-display-toggle" style="display:block;">
<div class="filter"><a href="#" title="more">Expand <span>Pm Picks</span> <i class="fa fa-plus"></i></a></div>
</div>
<div class="clearfix"></div>
<div class="ShowHideContainer box rightSidebar" style="display:none;margin-top:10px;">
<div class="clearfix">
<h3 class="blackHeading1"><a href="http://www.popmatters.com/review/bent-knee-land-animal/" class="mixTitle">Bent Knee: Land Animal</a> <span> //</span>
<a href="music/">Music</a>
</h3>
</div>
<div class="clearfix">
<h3 class="blackHeading1"><a href="http://www.popmatters.com/review/kane-strang-two-hearts-and-no-brain/" class="mixTitle">Kane Strang: Two Hearts and No Brain</a> <span> //</span>
<a href="music/">Music</a>
</h3>
</div>
<div class="clearfix">
<h3 class="blackHeading1"><a href="http://www.popmatters.com/review/wonder-women-25-innovators-inventors-and-trailblazers-who-changed-history-b/" class="mixTitle">What Can Women do? Pretty Much Anything: 'Wonder Women'</a> <span> //</span>
<a href="books/">Books</a>
</h3>
</div>
<div class="clearfix">
<h3 class="blackHeading1"><a href="http://www.popmatters.com/review/2-chainz-pretty-girls-like-trap-music/" class="mixTitle">2 Chainz: Pretty Girls Like Trap Music</a> <span> //</span>
<a href="music/">Music</a>
</h3>
</div>
<div class="clearfix">
<h3 class="blackHeading1"><a href="http://www.popmatters.com/review/rocqawali-sufi-spirit/" class="mixTitle">Rocqawali: Sufi Spirit</a> <span> //</span>
<a href="music/">Music</a>
</h3>
</div>
<div class="clearfix">
<h3 class="blackHeading1"><a href="http://www.popmatters.com/review/algiers-the-underside-of-power/" class="mixTitle">Algiers: The Underside of Power</a> <span> //</span>
<a href="music/">Music</a>
</h3>
</div>
</div>
<div class="ShowHideLinkLess pm-display-toggle" style="display:none;">
<div class="filter"><a href="#" title="more">Collapse <span>Pm Picks</span> <i class="fa fa-minus"></i></a></div>
</div>
</div>
<div class="adSpace box hidden-xs">
<div style="text-align: center;">  
<div id='MPU4'>
<script>
googletag.cmd.push(function() {googletag.display('MPU4');});
</script>
</div></div>
</div>
 
<div class="blog"> <a href="/blogs/home/" class="boxHeading"> <span>//</span>Blogs </a>
<h2><a href="http://www.popmatters.com/post/20-questions-kasey-chambers/">20 Questions: Kasey Chambers</a></h2>
<h3>// Sound Affects </h3>
<div class="blog-img"> <a href="http://www.popmatters.com/post/20-questions-kasey-chambers/"><img alt="" src="http://images.popmatters.com/blog_art/k/kaseychambers2017thumb.jpg" class="imgOverlay"></a> </div>
<div class="row">
<div class="col-md-12">
<p><span class="firstcharacter">"Australia's</span> country great Kasey Chambers embraced her ambition on a new double-album, but still wants to be remembered as "being real in a very fake world."</p>
<a href="http://www.popmatters.com/post/20-questions-kasey-chambers/" class="readMore">READ the article</a> </div>
</div>
<div class="row">
<div class="col-md-12">
<ul class="sidebloglist">
<div class="ShowHideLinkMore pm-display-toggle" style="display:block;">
<div class="filter"><a href="#" title="more">explore <span>BLOGS</span> <i class="fa fa-plus"></i></a></div>
</div>
<div class="ShowHideContainer content" style="display:none;">
<li><a href="http://www.popmatters.com/post/black-milk-gives-em-hell/">Black Milk Gives 'Em 'Hell'</a><br/><span> by Imran Khan</span> <span class="dateStamp">8 Jun 2017 // 11:30 AM</span></li>
<li><a href="http://www.popmatters.com/post/now-hear-this-hoops/">Now Hear This!: Hoops</a><br/><span> by Evan Sawdey</span> <span class="dateStamp">7 Jun 2017 // 9:00 AM</span></li>
<li><a href="http://www.popmatters.com/post/rhiannon-giddens-american-songbook/">Rhiannon Giddens Shares 'Freedom Highway' at American Songbook and on Tour</a><br/><span> by Sachyn Mital</span> <span class="dateStamp">2 Jun 2017 // 11:00 AM</span></li>
<li><a href="http://www.popmatters.com/post/slowdive-brooklyn-photos-bonus-song/">Slowdive Sell Out Brooklyn and Release Bonus Song "30th June"</a><br/><span> by Sachyn Mital</span> <span class="dateStamp">25 May 2017 // 8:54 AM</span></li>
<li><a href="http://www.popmatters.com/post/on-a-bang-an-interview-with-biffy-clyro/">On a Bang: An Interview with Biffy Clyro</a><br/><span> by Paul Carr</span> <span class="dateStamp">17 May 2017 // 11:32 AM</span></li>
<li><a href="http://www.popmatters.com/post/the-second-time-around-an-interview-with-tuxedo/">The Second Time Around: An Interview with Tuxedo</a><br/><span> by Danilo Castro</span> <span class="dateStamp">15 May 2017 // 9:00 AM</span></li>
<li><a href="http://www.popmatters.com/post/john-morelands-feeling-some-big-bad-luv/">John Moreland's Feeling Some Big Bad Luv</a><br/><span> by Sloane Spencer</span> <span class="dateStamp">1 May 2017 // 8:59 AM</span></li>
<li><a href="http://www.popmatters.com/post/person-youd-be-proud-of-an-interview-with-cataldo/">Person You'd Be Proud of: An Interview With Cataldo</a><br/><span> by Mantas Krisciunas</span> <span class="dateStamp">27 Apr 2017 // 9:30 AM</span></li>
<li><a href="http://www.popmatters.com/post/keeping-dry-under-storm-clouds-an-interview-with-sleaford-mods/">Keeping Dry Under Storm Clouds: An Interview with Sleaford Mods</a><br/><span> by Dan Derks</span> <span class="dateStamp">19 Apr 2017 // 10:50 AM</span></li>
</div>
<div class="ShowHideLinkLess pm-display-toggle" style="display:none;">
<div class="filter"><a href="#" title="more">Collapse <span>BLOGS</span> <i class="fa fa-minus"></i></a></div>
</div>
</ul></div></div>
</div>
 
</div>
 
</div>
</div>
</div>
</div>
 
<footer>
<div class="footer">
<div class="container">
<div class="row">
<div class="col-md-2 col-sm-3 col-xs-12">
<h4>ABOUT</h4>
<ul class="footerLink">
<li><a href="http://www.popmatters.com/about" title="About">Mission</a>
</li>
<li><a href="http://www.popmatters.com/contributors" title="Staff">Staff</a>
</li>
<li><a href="http://www.popmatters.com/about">Contact</a>
</li>
</ul>
</div>
<div class="col-md-2 col-sm-3 col-xs-12">
<h4>JOIN</h4>
<ul class="footerLink">
<li><a href="http://www.popmatters.com/submissions" title="Submissions">Submissions</a>
</li>
<li><a href="http://www.popmatters.com/book-imprint" title="Book Imprint">Book Series</a>
</li>
</ul>
</div>
<div class="col-md-2 col-sm-3 col-xs-12">
<h4>biz</h4>
<ul class="footerLink">
<li><a href="http://www.popmatters.com/advertising" title="Advertising">Advertising</a>
</li>
<li><a href="http://www.popmatters.com/privacy-policy" title="Privacy Policy">Privacy Policy</a>
</li>
</ul>
</div>
<div class="col-md-2 col-sm-3 col-xs-12">
<h4>FOLLOW us</h4>
<ul class="footerLink">
<li><a href="http://www.popmatters.com/feeds/list" title="RSS">rss</a>
</li>
<li><a target="_blank" href="http://www.facebook.com/pages/PopMatters/6658573343">Facebook</a>
</li>
<li><a target="_blank" href="http://twitter.com/popmatters">Twitter</a>
</li>
<li><a target="_blank" href="https://soundcloud.com/popmatters">Soundcloud</a>
</li>
<li><a target="_blank" href="https://www.pinterest.com/popmatters/">Pinterest</a>
</li>
</ul>
</div>
</div>
</div>
</div>
<div class="copyright"><div class="container">
&copy; 1999-2017 PopMatters.com. All rights reserved. PopMatters is wholly independently owned and operated.
<span></span>
</div>
</div>
</footer>
 
 
<script src="http://www.google-analytics.com/urchin.js" type="text/javascript"></script><script type="text/javascript">_uacct = "UA-286897-1"; urchinTracker();</script>
<script type="text/javascript">
var _sf_async_config=
{uid:21097,domain:"popmatters.com"}
;
(function()
{
  function loadChartbeat() 
{
    window._sf_endpt=(new Date()).getTime();
    var e = document.createElement('script');
    e.setAttribute('language', 'javascript');
    e.setAttribute('type', 'text/javascript');
    e.setAttribute('src',
       (("https:" == document.location.protocol) ? "https://a248.e.akamai.net/chartbeat.download.akamai.com/102508/" : "http://static.chartbeat.com/") +
       "js/chartbeat.js");
    document.body.appendChild(e);
  }
  var oldonload = window.onload;
  window.onload = (typeof window.onload != 'function') ?
     loadChartbeat : function() 
{ 
oldonload(); loadChartbeat(); 
};
}
)();
</script>
 
<script src="//cdn.popmatters.com/js/site.js?v=2"></script>
</body>
</html>
